Every project gets stuck on 39%

I am new to unreal engine.I selected the film making project type and downloaded the plugins required for it.But then the editor just gets hanged on 39% or sometimes 45%.
Please help me.

it’s not abnormal unfortunately, give it an hour to try and load. the next time you reopen the same project it will be faster, generally.

Happened to me yesterday after first time running 4.24 using film template then I just let it do whatever it is doing and went to lunch. UE opened by the time I got back and haven’t had a long loading anymore after that.

Maybe you have to let it run a little while first?

Agreed, @IndieGameCove. Often this just means the editor/engine is compiling shaders for the first time, and once it finishes, the next times the editor is opened, it will open very quickly.

If you’re ever uncertain whether the editor is “broken” during startup, or whether it’s just quietly compiling shaders or doing work in the background, you can check your Task Manager (or equivalent on other operating systems) to take a look at how much CPU resources the editor is using. If the editor is unresponsive but is consuming some significant CPU cycles, try to wait it out and see if it eventually opens. (In my experience, it always does eventually!)

Same for me, just starting a new project. Stuck at 39%

1 Like

I had the same problem. I deleted the Config folder in the project and it worked.

Deleting config folder inside project worked for me too.

It works! Thank you.

Yeah, deleting Config folder in project worked like a charm. But all project settings are obviously gone, and as soon as I update them to the VR settings I want, I have to go through the same process that gets stuck (this time stuck at 45% for at least an hour). Is there some specific setting that causes this? Can I get the project to force open without ‘compliing shaders’ or whatever it is doing?

It may be the case to be worse if raytracing is turned on. There is a lot of troubleshooting here:

I had one new project take around five minutes with raytracing turned off.

So if i delete the config folder it works. BUT i can not get the virtual textures on for the udims.
Has anyone been able to solve this problem?

Compiling shaders thats why i have the same problem. Waiting is the answer

In your project Config folder, find the file DefaultEngine.ini. Open it with notepad editor, and find the section below:
set the values to false


1 Like

Saved the day!!!

Which Config folder? I deleted one but it gave a crash error.

For anyone having this problem, I had it occuring when I enabled virtual texture rendering in Project settings, upon restart it got stuck at 45% then restarted again, and got stuck on 39%. It really takes only time in 30 minutes my project booted up, and started to compile all the shaders. Just wait, and delete anything if you already have a project

Please watch this Unable to start Unreal Engine, stuck at 39% ( SOLVED 100 % ) Unreal Editor initializing error - YouTube worked for me 100 % :slight_smile: i made this video after solved problem

Please watch this Unable to start Unreal Engine, stuck at 39% ( SOLVED 100 % ) Unreal Editor initializing error - YouTube worked for me 100 % :slight_smile: i made this video after solved problem

This is the reason why I got stuck, just remove the code that uses ConstructorHelpers in the GameMode constructor and it can be solved