Events not triggering BP

in your blueprint class defaults ensure that start with tick enabled is checked.

Are you sure you are spawning this character then? Is it the same if you just drag and drop into the level? Just trying to cover the basics here.

Only time anything like this has happened to me I had to restart the editor. Do you get any warnings or errors in the log?

My Events wont trigger anything (I also tried breakpoints) do you guys have any clue

it is I even tried “Tick Even when Paused” but also the Event Begin Play dose not trigger

I have placed it in the level

No and since i´m crashing often becoause of a coding problem the editor has restarted many times

it extends a Blueprint based on a c++ class based on ACharacter

Assuming that this extends ACharacter (based on the inherited components) does an ACharacter Tick? Also is this a C++ or BP based class?

The key is to narrow down the problem into chunks.

Does the base blueprint tick when placed without being extended?
Does ACharacter Tick without being extended?

If the answer to any of those is no then there is a lower lying problem likely inside your C++ code.