Event "Notify Fired" firing before the gun actually fires

UPDATE: issue was initially noticed using Revive for the Vive. issue doesn’t occur using Rift CV1.

Skip to the last post in thread for steps on reproducing the issue.

The Fire pressed threshold is set to .8, by default, but I’m getting the Notify Fired event at a little after .5

Could be a bug with the revolver only?
I’ll try to set up the same thing on a regular handgun and post back with the results.

is a followup.

Modified BPs (in the same exact way) on a custom pistol and didn’t see the problem.

Modified BPs (in the same exact way) on a new custom revolver, and the problem occurred. I left ALL vars at default, except for Refire Time, which I set to 1. (Refire Time seems to have no effect anyway, though it does have effect on the handgun.)

In the Anim BP, I do nothing but modify bone translation and scale (just like Zak did), so I didn’t post a ss of it.

Here’re the screens showing all of the BP changes I made:

The event graph

3 functions called in event graph
(1 on begin play)

(2 on notify fired)

Trigger Pull (mid-left) is at 0.54~ when in the Notify Fired event.

“Fire Trigger Pull” (top-right) is set to 0.8.

Tried on another, new Custom Revolver mod and left everything at default (default mesh and AnimBP setting; i.e., no AnimBP), and it didn’t function properly.

  • Added a Notify Fired event in the mod’s event graph and the event got hit with Trigger Pull at around ~.5 (Fire Trigger Pull was left at default 0.8).
  • After that, I changed Refire Time to 1 and was able to shoot as fast as I could pull the trigger.

Created a new custom pistol and custom Shotgun, set up **exactly **the same as the new Custom Revolver, and they functioned properly.

  • There’s no Fire Trigger Pull variable to adjust, so I didn’t check that
  • Changed their respective Refire Time to 1 and was only able to shoot once a second (as expected).

Here’re more simple steps to reproduce:

  1. Create “Custom Revolver” mod
  2. In its event graph, add a “Notify Fired” event and connect “Notify Fired” to a Print String.
  3. Feed in a “get Trigger Pull” to the “in String” input on the Print String.

Printed string is between 0.1 ~ 0.55 (slower you pull the trigger, the closer to 0.5 it’ll be)

Expected Result:
Fire Trigger Pull’s comment says: “Pull at least far to fire”, so I’d expect the printed string to be 0.8 (the default value of “Fire Trigger Pull”)

Unfortunately, I can’t explain it any simpler than .

Bump (Assuming RR modding isn’t dead.)

I’m pretty sure I’ve described the issue well enough, provided more than enough info to reproduce the issue, and waited long enough for some answer/criticism (3 weeks).

We i get back to my PC in a few hours i will have a look through and see if i notice anything for you.

EDIT : do you want the hammer to move with the more as you press the trigger? As in if the trigger is half pressed the hammer is half back? or just go with each shot?

Hey ,
Sorry to bother you, but thanks a lot for the reply. I’d prefer the former, but either is OK.
(It’s the default behavior for revolver mods I believe.)

Currently, the hammer moves back in unison with the trigger and it comes down at .8 (default Fire Trigger Pull).

The Notify fired event is the thing that’s got me scratchin’ my head. It’s getting fired before the 0.8 (at ~0.15 to ~0.5). causes my custom sound and particle effect to play, (and my special bullet logic to run), but a bullet never leaves the gun until I go past 0.8.

Basically, the notify fired is triggering too early and then getting canceled somehow.

I get lost in the revolver BP because it’s “inheriting from something” * 4.

are you happy to send me the project to look at?

You’re not seeing issue with a brand new custom revolver? Let me see if I can can zip up my custom one. There was an update, after I verify it’s still no good, I’ll shoot you a google drive link to the zip.

Thanks again for the help. I pm’ed you the link.

Did the Pm I sent you fix it?

Hey . Unfortunately, no. It didn’t. I pm’d you the day after you gave me the link to the fixed version. I was hoping you could tell me what exactly you changed. Only thing I noticed was that one of my custom functions was moved to before firing the parent Notify Fired.

Hey replied via PM

All was fine on my end once the changes was made :slight_smile: