Download

Event Bind target expects a type of SKEL_X but the dispatcher is of type BP_Character

Hi! Im trying to create a simple event that should be called by my character and consumed by the level blueprint.

However… For some reason when drag and droping the event dispatcher from my character to the level blueprint and adding the “Bind”… the binds target-property expects a type of SKEL_BP_Character_C?..SKEL???

BP_Character:

Level blueprint:
18211-skärmklipp2.png
Didnt manage to get a screenshot with the tooltip shown for the property… but as mentioned it expects a type of SKEL_BP_Character_C (Or as it says SKEL BP Charcater C)

Any ideas of what to do with the target-property?

Br, Inx

I just had the same issue fixed literally 10 mins ago :slight_smile:

Go into your Editor Preferences, and in the experimental features section, un-check “Use New Blueprint Menuing System”, it is looking for a type that doesn’t exist and can’t be created (SKEL… type), so you will need to use the old menu system for now, this fixed it for me.

See here for more info:

https://answers.unrealengine.com/questions/117937/blueprint-communication-changed-in-45.html#answer-118636

Oh, thanks I will try that soon and get back with a “report” :slight_smile:

It was already disabled so I tried to enable it and re-wire the event… that didnt work, so I removed the Event Dispatcher and the “wireings”… and disabled the option you mentioned and restarted the editor, and then re-wired all of it and added the dispatcher but still having the same issue :(.

Do you have anything else turned on in experimental?

Also, make sure you delete any nodes that reference a SKEL type, and compile the blueprint before turning it off, you will need to re-create the nodes afterwards. I just tested that and leaving them on will keep the issue active.

EDIT: and you don’t need to restart to fix this, it will happen immediately when it is turned off/on.

All the experimental features are turned off, I alos just tried to create a clean new project based on the first person template, I made sure that all the experimental features were turned off, and then I opened the MyCharacter BP and added a “F Pressed event” and wired that to a Call to a new dispatcher called NewEventTest (Call NewEventTest), after that I opened the Level BP and dragged and dropped my NewEventTest-dispatcher from the MyCharacter BP into the Level BP and picked “Bind”… after that I hovered over the Target-property and it still says that it expects a type of SKEL My Character C.

Any ideas :/?.. or am I doing something wrong when creating the event and the dispatcher?

I also just tried to do the same thing in 4.4.3… and it still seems to expect a type of SKEL_XXXX :/…

That is really odd… I just tried the same thing and you are right, the Bind event is asking me for a SKEL My Character C as well in version 4.5.

I also went ahead and attempted the same thing in version 4.4.3, and it also does not work (asks for the SKEL type same as above).

So in your case this setting has nothing to do with it, however I do not know why it is happening… I will get back to you if I find a solution (hopefully someone who has dealt with this situation can help here as well), going to try a few things out. :slight_smile:

Ok, to be a bit egocentric Im glad it wasnt just me hehe :), please let me know if you find out anything more :slight_smile: