Event BeginPlay Node Not Working?

Hi, Today I launched UE 4.15 to work on my game which I was very excited about and to my disappointment nothing worked like it used to yesterday when I saved and quit the engine, so I thought to my self what could be causing the widgets to fail the cast leaving the variables null. So I looked at the level bp which spawns my main menu widget and this is what I found. The Event BeginPlay node was clearly not working because It wasn’t spawning the widget so I tried plugging the Use Button (E) To see if that could trigger the widget to spawn and It did. I don’t really what could of caused this as everything worked perfectly yesterday, but for now until I get an answer I can’t do anything :confused:

Best Regards,

Hello ,

I was not able to reproduce your issue on our end. I have a couple of questions that will help me narrow down your issue.

  1. Can you reproduce this issue in a new project?
  2. If so could you provide a detailed list of steps so I can reproduce this issue on our end?
  3. Are you using a custom GameState or GameMode in your project?

Hi, thanks for the answer! Hope this helps :slight_smile:

  1. I can’t :stuck_out_tongue: Everything seems to be working fine.

    • Can’t answer because I don’t really know what happen and yesterday everything was fine.
  2. I’m only using a custom Game Instance, But even when I change it to default it doesn’t work.

Best Regards,

Would you be willing to send me your project so I can look into your issue further? You can private message it to me on the forums via this link here:

I’m so sorry for taking up your time but I really didn’t know that my GameState changed so just by changing it back everything started working :stuck_out_tongue: Anyway thank you :slight_smile:

Best Regards,

Glad to know things are working for you now!

Good luck on your project!!

Thanks a lot :slight_smile: I will let you know when I’m done :slight_smile:

Best Regards,