Download

Eu4.exe not building. Can't run from Visual Studio

I was working away this afternoon, when for some unknown reason when I tried to launch the UE editor from VS2017 I got the following message:

Unable to start program "C’Program Files\Epic Games\UE_4.25\Engine\Intermediate\Build\Unused\Ue4.exe’. The system could not find the file specified.

After checking I found that yes indeed that file does NOT exist. Not sure why UE is looking for that file but, it is.

I have been running (and I’m still set to run) using DebugGame Editor Win64.

Right clicking and bringing up the properties for my UE4 project in Visual Studio 2017 I see that both the Output Directory and the Intermediate Directory are both set to the above mentioned path.

Things I have tried to resolve this with no luck: (I’ve tried most of these several times)

Quit VS, rebooted my Computer (Windows 10)

Rebuild Solution

Right clicking on my Unreal uproject and selecting “Generate Visual Studio project files”

Uninstall and reinstall UE 4.25.3

When I select Build->Rebuild Solution in VS my output gives the message:
1>------ Skipped Rebuild All: Project: UE4, Configuration: BuiltWithUnrealBuildTool Win32 ------
1>Project not selected to build for this solution configuration

In Visual Studio’s Configuration Manger with DebugGame Editor Win64 selected as the Active configuration and platform, The project UE4 only has the configuration BuiltWithUnrealBuildTool and platform Win32. The build box for UE4 is not checked, but checking it does not seem to fix anything.

Anyone have any ideas what might have gotten messed up, and why I don’t have an UE4.exe file? Or how to get one? Given it is in the Install location I would have thought it would just be there, but it isn’t.

Thanks,
Chip

I found that reinstalling the Visual Studio extension, UnrealVS fixed this. Not sure what happened to cause UnrealVS to require reinstall, but that fixed it.

Check if your project is set as the start up project, if not so, set it by right clicking your project in Visual Studio and checking set as startup project , this might resolve the issue.