Download

Essential Tress Pack, what am i doing wrong?

Do I downloaded the free pack from this forum and managed to import the package and drop tress and all. But I cant seem to figure out what I am doing wrong. All the models including grass and such get imported with no textures. I did follow the Indian guy voice video in which he teaches you how to import downloaded assets into your project and I cant seem to get the textures to get imported to the meshes. I have to mnually hunt down the files and apply them to the materials they came with. any help?

Its odd… I put the folder in my project folder and i am able to load the meshes but as soon as i click to drag a tree over to my viewport, the whole tree goes grey with no materials. the Kite Demo works fine. its just the downloaded files from here. any clue?

https://forums.unrealengine.com/comm…ge-starter-kit

thats the file. Could it be that the package is for a older UE4? I am under 4.17

And if thats the case… (outdated package) can you guys point towards a package that will work with 4.17 and above? seems like almost all of them here wont work with texture out the box.

Hey syrom!

Have you tried posting your question in that thread for support? I’m not familiar with that asset pack, but essentially what you’d want to do is copy the contents of the Content folder into your destination project’s Content folder. It appears that that pack should work with any engine version 4.7 and above so it should work with 4.17.

in the thread… i read this.

Unfortunately it just works with > 4.7 because of the foliage shading mode which was used in the material -> for a version before 4.7 you will have to reimport the meshes + set up new materials, but when you like I can upload a small package that will also work with the > 4.5 :slight_smile:
-you just have to open the static mesh editor - asset - reimport - choose the file

Edit:
@sanford8
Yep, that’s right :smiley:

SO i figured its not just me. Also… the editor we download is 4.18. why do people say they have 4.7 or higher? what am i missing?

ok. it worked. the migration tool actually worked. i did it so many time that it actually took hold . weird

Turned out a grass package was the issue.i dL 4 zip files and wanted grass badly that I would always try that first. Well… that zip file is the only one that doesn’ work properly, all the other do once you relaunch the map.

You asked this on that profuct thread already… I have told you in that another thread, that the content you are downloading is a complete project. You can’t just copy it as a whole to another project. Unzip it, Looking at its contents you will find a .uproject file, just double click it to open the editor. Once in the editor, wait for the shaders to compile. Once this is done, you can pick the tree you want, right-click → Asset Actions → Migrate and then you will choose the destination project you want that tree to go, but you must be sure to select the Content folder on that project.

Simple as it is.

yep… took me a few tries to figure it out. Thanks for the explanation.