Download

ES3.1 Preview Crashes Editor

Hey there,

If,

  • Mobile HDR is off (You need this off to turn on Multi-View)
  • Mobile Multi-View is on

Editor doesnt crash when previewing ES3.1. But if you change Mobile MSAA to anything other than No MSAA, it will crash and wont open again.

This doesnt cause problem with the packaged projects. It just crashes the editor. So you can change Mobile MSAA before you package. But this wasnt happening in earlier engine versions.

So if you are developing for Oculus Quest, you problaly have these settings and you might encounter this. Hope this helps you.

@Monster1234 saved my ass… thanks a lot

I can confirm that the issue is still present as of version 4.25.3, as soon as I try to launch the ES3.1 Mobile Preview the engine crashes with this error message:


Fatal error: [File:D:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/Windows/D3D11RHI/Private/D3D11Util.cpp] [Line: 258] Direct3DDevice->CreateRenderTargetView(TextureResource,&RTVDesc,RenderTargetView.GetInitReference()) failed at D:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/Windows/D3D11RHI/Private/D3D11Texture.cpp:810 with error E_INVALIDARG

Has anyone found a solution to this problem?

I dont think there will be a solution to this in 4.25. But you can use workaround I mentioned.

A slightly nicer workaround is

  • in DefaultEngine.ini set r.MobileMSAA=0
  • in Device Profiles for Android, set it back to =4

Or do the same thing for vr.MobileMultiview, but for some reason, the vr.* console settings are not exposed to the editor in Device Profiles, so you have to put it in DefaultDeviceProfiles.ini manually.

Then you don’t have to fiddle with it before packaging.

Thanks @Monster1234 My editor crashed as it was switching and then crashed on subsequent loads and the MSAA setting was the culprit.

Just adding some info that hopefully might flag this post in other peoples searches. I was getting and assert in RenderGraphBuilder.cpp in FRDGBuilder::PrepareResourcesForExecute the following check was failing:

check(Texture->ResourceRHI);

Is anyone still having issues with this? I was having the error OP mentioned then I changed the DefaultEngine.ini as recommended now I just get this. :mad:


Fatal error: [File:D:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/RenderCore/Private/RenderingThread.cpp] [Line: 855]
Rendering thread exception:
Assertion failed: IsInGameThread() [File:D:\Build\++UE4+Licensee\Sync\Engine\Plugins\Runtime\Steam\SteamVR\Source\SteamVR\Private\SteamVRHMD.h] [Line: 171]



0x00007ffa79c93b29 KERNELBASE.dll!UnknownFunction ]
0x00007ff9d7f5e9e6 UE4Editor-Core.dll!UnknownFunction ]
0x00007ff9d7f61dc8 UE4Editor-Core.dll!UnknownFunction ]
0x00007ff9d7cee53d UE4Editor-Core.dll!UnknownFunction ]
0x00007ff9d7c797b5 UE4Editor-Core.dll!UnknownFunction ]
0x00007ff9d7c7baf0 UE4Editor-Core.dll!UnknownFunction ]
0x00007ff9b04572d0 UE4Editor-SteamVR.dll!UnknownFunction ]
0x00007ff9d54f5093 UE4Editor-Engine.dll!UnknownFunction ]
0x00007ff9b2d7aea0 UE4Editor-SlateRHIRenderer.dll!UnknownFunction ]
0x00007ff9b2d82c23 UE4Editor-SlateRHIRenderer.dll!UnknownFunction ]
0x00007ff9b2d8a0dc UE4Editor-SlateRHIRenderer.dll!UnknownFunction ]
0x00007ff9b2d811f5 UE4Editor-SlateRHIRenderer.dll!UnknownFunction ]
0x00007ff9b2d93c0e UE4Editor-SlateRHIRenderer.dll!UnknownFunction ]
0x00007ff9d7a987d8 UE4Editor-Core.dll!UnknownFunction ]
0x00007ff9d7a98aa3 UE4Editor-Core.dll!UnknownFunction ]
0x00007ff9d405f892 UE4Editor-RenderCore.dll!UnknownFunction ]
0x00007ff9d40653d4 UE4Editor-RenderCore.dll!UnknownFunction ]
0x00007ff9d7f8025b UE4Editor-Core.dll!UnknownFunction ]
0x00007ff9d7f77c30 UE4Editor-Core.dll!UnknownFunction ]
0x00007ffa7be67bd4 KERNEL32.DLL!UnknownFunction ]
0x00007ffa7cc2ce51 ntdll.dll!UnknownFunction ]





[/Script/Engine.RendererSettings]

r.Mobile.DisableVertexFog=True

r.Shadow.CSM.MaxMobileCascades=2

r.MobileMSAA=0

that’s really save my ■■■!