Errors while packaging for windows 64bit

Hello,

I tried to fix all the errors I could on my own, but I still get
PackagingResults:Error: Error Unknown Cook Failure

Here is the output log:
https://docs.google.com/document/d/14emVkSHavUdPi_H86nkNFlC3WNEBlXuVlFiEyFJ9Z_k/edit?usp=sharing

Thanks in advance!

Hello acef596,

Thank you for including your log in your initial post. This is very helpful for diagnosing the cause of your issue.

The main problem that stands out to me is this one:

WARNING: Visual C++ 2015 toolchain does not appear to be correctly installed. Please verify that “Common Tools for Visual C++ 2015” was selected when installing Visual Studio 2015.

This means that there is a missing component of Visual Studio that is required for compiling in UE4. You can find out how to fix that here: https://answers.unrealengine.com/questions/412747/build-failed-windows.html

There are also some other warnings that mention missing files and some blueprint problems. The easiest way to find these would be to open the log in a text editor (even notepad works) and hit Ctrl+F to bring up the find feature. Search for Warning and wade your way through. For the missing file ones, see if those files are indeed missing. If so, either replace them or get rid of the references. As for the blueprint ones, they should explain what is needed from the messages themselves.

Thank you! Problem solved. :slight_smile: