Errors running dedicated server compiled from source

I have been following this guide and twice now I’ve started from scratch to come to the same errors.

After cooking the content and compiling the (Development) server followed by the (Development) client I launch the MultiplayerTestServer.exe -log and get this output followed by a messagebox also showing the CDO constructor errors.

Starting the client yields the same messagebox with CDO constructor errors, followed by a message with this error:

Assertion failed: GDefaultMaterials[Domain] != NULL [File:D\Projects2\Unreal Projects\EngineBuild\Engine\Source\Runtime\Engine\Private\Materials\Material.cpp] [Line: 351]
Cannot load default material

This is the second time it’s happened, am I consequently doing something wrong following the guide?

For now I have fixed it by ignoring the tutorial in step 8 (“Deploy: Do not deploy”) and actually choosing to deploy to my device, this set the files in the right locations.

I’m experiencing this issue in 4.17 where the answer above doesn’t seem to apply anymore, but the problem stays the same.
i’ve tried packaging to a .pak file aswell as to a loose content files. also tried removing the WorldGridMaterial from my game, including the editor content and rerouting the DefaultMaterial path from the BaseEngine.ini file to something that is included in the packaged content for sure.
Nothing helped. I’m stuck here. Any help is appreciated.