Download

Errors in library

When I first log in to UE launcher and I go to the library tab, I asm finding that the versions of the engine being shown are for 4.21.* It does not give me access to anything later than this. To get to those later builds I have to exit the launcher and restart it. Then I get the correct engine versions showing. This happens every time I log in.
any idea whats happening?

regards
Antony