Errors building 4.4 engine code

Hey guys,

I am trying to build the 4.4 engine code but I am having the following errors pop up on me (See Attached…)

I do not have an occulus rift, but I assume the is because of error “cannot open input file ‘libovr64.lib’”. First I tried to build from my old repo that was updated to 4.4 from 4.2, but that failed with the same error. Since I had not actually made any changes (just studying code), following the instructions I created a new fork, cloned, installed required files (downloaded this morning), but I still receive the same errors. I am building with “Development Editor” and “Win64”.
I have had the code build properly for me the last time I tried, but I also re-downloaded the DirectX Runtime and re-installed just to be safe.

The only other thing I have done is updated Visual Studio to the new Update 4 CTP 1 update (after reading about the nice performance increases! ).

Any ideas on what might be causing this?

Hi ,

Unfortunately we missed including the latest Oculus library in the dependencies for 4.4, even though the Engine source code requires it. You can get the necessary files directly from Oculus here. Just extract the zipped file to the root folder of your Engine installation and everything should drop into place.

Thank you !

My build just completed without any errors :slight_smile: