Download

Error while trying to compile.

I’m trying to compile a project but receiving this error "System.MissingMethodException: Method not found: ‘Void UnrealBuildTool.ModuleRules.set_PCHUsage’. I’ve searched around and found few references to to this error. This project is 95% blueprints that was upgraded from an earlier version of Unreal to 4.23. I’ve have other projects which are 95% C++ that compile with no problems.

The project runs fine in the editor. I was attempting to build a package on Windows when I encountered this. Please note, this same project packaged successfully before the upgrade.

I’m not sure where to categorize this post. Please move it if it’s in the wrong place.

Thank you!

Hi, what is the output log printing when you hit the Launch button?

Some warnings about no context. Errors are the same as above "ERROR: Unable to instantiate module ‘<Module Name>’: System.MissingMethodException: Method not found: ‘Void UnrealBuildTool.ModuleRules.set_PCHUsage(PCHUsageMode)’ and also “Launch failed! Unknown Error”

Next I would install debugging symbols if not done already, and verify the engine install. Also take a look into all three logs, one is linked on the Crash Client Popup window, to a location inside AppData, one is inside the Saved/Crashed folder, and one inside /Saved/Logs/ - in particular search the log files for keyword ‘Error’, and browse to the bottom of each file and check for latest issues there. Perhaps you try to package for a operating system where you’re missing some prerequisite files, or your engine version is damaged.

Thank you @Luminary for pointing me in the right direction. I decided to upgrade to 4.25 since I was going to have to download about 60Gb of data anyways. This solved the packaging & launch problem. My guess is there was something wrong with the engine install.

My first posts here. Is there a way to close this topic or mark it as solved?

Great you could figure this out. For closing, just edit your initial post and add [SOLVED].