Download

Error while starting Shooter Example

I don’t know what is wrong with UE4 but my Driver crashes all 10s-30min and the most example projects don’t want to start…
I guess Nvidia payed you to not support AMD cards…

Could you also post your specs or the dxdiag file? :slight_smile:
+report it on answerhub: https://answers.unrealengine.com/
+are your drivers up to date?

I have a similar problem in 4.8 with the stylized rendering project and even with the content examples. Nonetheless in 4.7.6 I have no problems, I hope that the Nvidia drivers make a difference in OS X.

My PC was NEVER NOT up to date. Updates are made all 12h + Advanced System Care PRO + Avira Antivir

I want to post it on this hub but i got 2x error so first you should fix your interial error and then ask people to post something. I wasted 15-20min of my life for something that gave me 2x interial error.

Hi DerPolacke,

fighter5347 was trying to help, please do not take your frustrations out on him. The reason he asked you to post to the answerhub was so that we can better track and assist you with this specific error. Are you still having a problem posting to the answerhub? If you are able to, please post the following information to answerhub in the bug reports section:

Can you post your dxdiag here so I can take a look and see what may be occurring? Additionally can you post your callstack and whatever steps you take just before the crash occurs. Have you tried verifying your engine version? To do this, go to the launcher>Library and click the drop down context menu then press “verify”. This will check to ensure that you are not missing any files or that no files have been damaged in the editor. If there are missing or damaged files, it will replace or repair them as necessary. Are you able to open a blank project or is this limited to sample projects? Have you set the editor as an exception in your firewall?

If you are unable to post to the answerhub, please post this information here.

Here is the dxdiag and this is the last line from the message:


LogPlayLevel: Project.CopyBuildToStagingDirectory: ********** STAGE COMMAND STARTED **********
LogPlayLevel: BuildCommand.Execute: ERROR: BUILD FAILED
LogPlayLevel: Completed Launch On Stage: Build Task, Time: 0.768037
LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception:
LogPlayLevel: Program.Main: ERROR: Exception in AutomationScripts.Automation: Missing receipt 'ShooterGame-Win64-Development.target.xml'. Check that this target has been built.
LogPlayLevel: Stacktrace:    bei Project.CreateDeploymentContext(ProjectParams Params, Boolean InDedicatedServer, Boolean DoCleanStage)
LogPlayLevel:    bei Project.CopyBuildToStagingDirectory(ProjectParams Params)
LogPlayLevel:    bei BuildCookRun.DoBuildCookRun(ProjectParams Params)
LogPlayLevel:    bei BuildCommand.Execute()
LogPlayLevel:    bei AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
LogPlayLevel:    bei AutomationTool.Automation.Process(String] CommandLine)
LogPlayLevel:    bei AutomationTool.Program.MainProc(Object Param)
LogPlayLevel:    bei AutomationTool.InternalUtils.RunSingleInstance(MainProc Main, Object Param)
LogPlayLevel:    bei AutomationTool.Program.Main()
LogPlayLevel: Program.Main: ERROR: Missing receipt 'ShooterGame-Win64-Development.target.xml'. Check that this target has been built.
LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes.
LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=1
LogPlayLevel: Domain_ProcessExit
LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_3d18_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_2f0c_0///####STATCAT_Advanced####
LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes.
LogPlayLevel: copying UAT log files...
LogPlayLevel: RunUAT.bat ERROR: AutomationTool was unable to run successfully.
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 0.000032
LogPlayLevel: BUILD FAILED
PackagingResults:Error: Error Launch failed! Unknown Error
LogD3D11RHI: InitD3DDevice

Here are my PC Specs:
i7 4790K
R9 380 Gaming 4G
2x4GB 2400mhz CL10 RAM
2x SSD 240GB
Asus Maximus VII Ranger Z97

Catalyst 15.7 (15.20.1046-150622a-186188C)
Direct3D 9.14.10.01128
OpenGL 6.14.10.13397
Mantle 9.1.10.0077

http://youtu.be/f5DL0SZ1izg

Your dxdiag does not show anything that is under our minimum specs so that should be fine. Did you try the verification process or other steps I listed in the above post? Have you tried posting to the answerhub again to see if you are still getting the internal error?

I did this Verifying thing and it said that it has backed up something.

In Shooter Sample are many missing files… it has been also deleted from Marketplace…
https://www.unrealengine.com/content-cat/assets/communitysamples

Have you downloaded the shootergame example from the learn tab of the launcher? There is a 4.8 version present there.

I downloaded it from Makretplace, i deleted it and now i download it again from learn section.

@Edit still doesn’t work. Missing files all the time…

the support in cryengine is more effective, they ask much and try to fix it… in UE4 i feel like in kindergarten… i try to make a game on UE4 but i cant… Crashing all the time… missing files… i know that my PC isn’t the problem but i know support thinks i’m to stupid… i build many PCs and overclocked them… this is my hobby since 2012… The log says that Shooter Game is missing some files. I ever reinstaled UE4… the whole launcher with engine and project… UE4 gives me more options to make a FPS game but the community is almost dead… all i ask no one cares or i read all the time… watch tutorials… ehhhhh

I have tested it several times and I dont get any errors. Which version do you use? + are you sure that you have downloaded the right version of the shoot demo? + have you installed visual studio express 2013/community? + do you still get the same log error as above? + how do you start the shooter demo project? + answer all questions from Adam + when you like you can add me in skype and we can try to fix it (nasph96) :slight_smile:

When you get crashes, just report them on answerhub with all needed information → log file, version, steps to reproduce the crash,… and always make sure to use a stable version!

The support team is just doing their job. They dont think that you are stupid -> they just want to be sure that you havent missed something (sometimes people forget to try some basic solutions -> even though it will solve their problem) :wink:

The community is not dead -> you always get help when you have any problems + we have many new and active members

4.8.2
If it’s the right one i don’t know i downloaded it from Learn section.
about the visual thing i’m not sure, but games that i made i can Launch but Shooter Game not.

Ok, lets see if we can solve the problem over skype :slight_smile:

Ok, we solved the problem with the missing shooter game files -> visual studios express was missing :cool:

Hi DerPolacke,

I apologize for the delayed response. We do not typically work over weekends. I was able to find what I believe may be the problem you are experiencing with your driver crash. There seems to be a slight memory leak in Shootergame, which I’ve reported as UE-19210 to be assessed by the development staff.

Now you write everything but at the beginning you couldn’t say anything? Fighter gave me some links and explained everything very well.