Error while generating project files from source


I try to compile the 4.3 source of the UE4 Engine and get this error in console:

Setting up Unreal Engine 4 project
files… C:\Program Files
(3528,5): error MSB3030: Datei
konnte nicht kopiert werden, da die
Datei nicht gefunden wurde.
GenerateProjectFiles ERROR:
UnrealBuildTool failed to compile.

  • First I downloaded the Github source + resources 1/2 + optional dependencies from here .
  • Then I unzipped and merged the files in the UnrealEngine folder.
  • Of course I installed the dx redist and Visual Studio 2013 (express).
  • After executing the GenerateProjectFiles.bat I get the following error and I don’t know where to find the UnrealBuildTool.exe!?

Do you know what’s going wrong?

  • OK, I tried to compile the UnrealBuildTool.exe with Development configuration (opened the UnrealBuildTool.csproj with Visual Studio).
  • Same error in Visual Studio (no UnrealBuildTool.exe found).
  • Then I copied the Debug build (yes, building this worked) into the Development directory.
  • After that I executed the GenerateProjectFiles.bat and tadaaa it worked.

Hope it will help some people running into the same issue! :slight_smile:

I have a problem running the “GenerateProjectFiles.bat” which gives me the error:

GenerateProjectFiles ERROR: UnrealBuildTool failed to compile.

. But i can also build it under debug in VS 2013 like you, but not develpment. What folder did you copy what exactly into? Only the “UnrealBuildTool.exe”? Mine is currently in “\GitHub\UnrealEngine\Engine\Binaries\DotNET” and the “GenerateProjectFiles.bat” still gives me the error i mentioned at the beginning.

Hi ,

Could you check your VS120COMNTOOLS environment variable to make sure it is pointing to the correct location? You can find the environment variables at Control Panel\System and Security\System -> Advanced system settings -> Environment Variables, and VS120COMNTOOLS should be pointing to the Tools folder inside your Visual Studio installation. Also, what version of Visual Studio 2013 are you using?

If you have Avast or possibly other anti virus software, you can disable it first to test the bat file. If so, you’ll want to create a permanent exception to the path or file.

From the Avast “Show Report File”

* avast! Real-time Shield Scan Report
* This file is generated automatically
* Started on: Saturday, August 02, 2014 3:44:17 PM

8/2/2014 3:54:12
PM	E:\GitHub\UnrealEngine\Engine\Binaries\DotNET\UnrealBuildTool.exe
[L] Win32:Evo-gen [Susp] (0) File was
successfully moved to chest...

But Avast is quite annoying and confusing to set up exclusions. First I went into settings and did so but it doesn’t apply to real-time scans. In order to exclude real-time scans, you need to click on File System Shield, hit the Expert Settings button, then add an exclusion to UnrealEngine\Engine\Binaries\DotNET. So basically put it in two places.

It would be great if this file didn’t cause a false positive in a virus scanner.

Building the solution via the bat file wasn’t enough, because when I tried to build the solution in VS, it also got isolated there… so I had to go deeper to basically exclude it permanently.