Error when trying to


I’m trying to build Unreal Engine 4.22.1 (release branch) on my pc with Linux Mint 19.1 Tessa.

During the build process, runs perfectly well and no errors are returned, outputting the final success message. However, on the next step of the install process, where I need to run, I get a compile error:

I’ve tried uninstalling all mono and unreal files several times now. I have also tried moving the unreal folder to another location and redoing it all again. Any help with this would be greatly appreciated!


I performed the setup and generate file process on a fresh install of mint 19 and did not have any problems.

Attached is a copy of my terminal output so you can compare it to yours.

Did you make sure to clean up the repo directory? I only ask because your screen shot shows that it has detected previous ~/.gdbinit settings which makes me think this repo directory may have also been used to install a previous version.

Hey !

Yes I did a full clean of everything related to Unreal on my disk, including a full removal of mono too. I think the problem stems from when I had to cancel the install the first time I tried, even though I cleaned it all out after. Or so I think! Did a full install again, making sure to remove the ~/.gbinit file and all the rest in /.config/Epic. Here is my terminal output: terminal output


Tried the release branch like you did still no problems…


  1. Verify any customization to your PATH are correct.
    I can see your PS1 is printing with a prefix ‘(base)’ so i am guessing you may have modified your .bash_profile a bit.
    It looks like that message is printing out your PATH, which from how that reads seems to be prefixed with “Desktop:” Is there something custom there you are doing?

  2. Get more messages out of the mono xbuild tool. It looks like the mono build is executed within the linux version of Try changing the ‘verbosity’ flag being passed to xbuild. Hopefully that gives you a better understanding of what that error is.

Change line 26 of



xbuild "$BASE_PATH/../../../Source/Programs/UnrealBuildTool/UnrealBuildTool.csproj" /property:Configuration="Development" /verbosity:quiet /nologo


xbuild "$BASE_PATH/../../../Source/Programs/UnrealBuildTool/UnrealBuildTool.csproj" /property:Configuration="Development" /nologo

Hope this helps,

Found the problem! Many thanks to (jfeister) for all the help!

My PATH variable was messing up in the installation due to when I installed GitHub Desktop, it had added itself as an entry with a space.

My pre-existing PATH variable was this:

(base) night@night-XPS-15-9560:~/UnrealEngine$ echo $PATH

/home/night/anaconda3/bin:/home/night/anaconda3/condabin:/home/night/bin:/opt/GitHub Desktop:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games

So I removed that entry from PATH with a nifty line in terminal I got from user Lurchman at this page:

PATH=$(REMOVE_PART="/opt/GitHub Desktop" sh -c 'echo ":$PATH:" | sed "s@:$REMOVE_PART:@:@g;s@^:\(.*\):\$@\1@"')

This is still only a temporary fix and I wish to remove the GitHub Desktop PATH entry completely as I uninstalled the application anyway, so any ideas on this would be appreciated. Otherwise I will keep looking for where it has been entered, as I can’t seem to find it in any of the bash files.

EDIT: Restarted system after uninstalling GHDesktop and the path variable was fixed.

Glad to hear you figured it out.

As far as the PATH setting. Looks like from this file for github desktop

They create an ‘/etc/profile.d/’ that sets up your path for github desktop. Since you said you wont be using github desktop anymore see if the ‘/etc/profile.d/’ file exists and remove it.

For your reference all .sh files in that ‘/etc/profile.d/’ directory are sourced by the system wide startup profile file ‘/etc/profile’, which is sourced when a bash shell is started. Good to use if you want to enforce system wide policies.

Thankyou for all the help!

The problem to this was actually just that a restart was required after uninstalling it. :slight_smile: