Error when building from source: libUE4Editor-UnrealEd.so

I would really appreciate any help on this. Trying to install UE4 on Linux and get the following error when I try to make the UE4Editor.

[

826/1078] Link
libUE4Editor-UMGEditor.so ERROR: UBT
ERROR: Failed to produce item:
/home/yousaf/.local/share/Trash/files/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-UnrealEd.so
Total build time: 2254.89 seconds
(Local executor: 0.00 seconds)
Makefile:188: recipe for target
‘UE4Editor’ failed make: ***
[UE4Editor] Error 5

Also worth mentioning there were errors before this but they did not halt the compile process. If there’s any logs I need to attach just let me know which ones and I’ll have them up shortly.

The first thing I noticed right off is that it looks like its trying to put your Linux executable files in the trash. What instructions are you using to install it? Where are you cloning your files from Git into?

Okay I was previously working with an older version, now I downloaded the latest version and it still gets stuck at the same spot. This time it literally got stuck and I had to hit ctrl-c.

[834/1078] Link
libUE4Editor-UMGEditor.so ERROR: UBT
ERROR: Failed to produce item:
/home/yousaf/Desktop/UnrealEngine-release/Engine/Binaries/Linux/libUE4Editor-AppFramework.so
Makefile:188: recipe for target
‘UE4Editor’ failed make: ***
[UE4Editor] Interrupt

Also I don’t think it matters but I actually downloaded the file instead of cloning it

You’re right. You don’t need to clone Unreal Engine into a directory but you do need to make sure you’re following a specific sequence and that you have all prerequisites installed. The reason I asked what instructions you’re using is because there is a definite sequence you need to use to install Unreal Engine. For instance, you may be missing a file or library needed to build everything properly. I have been able to build Unreal Engine 4.15 on Ubuntu 16.04 using the instructions on Epic’s Linux page. The very first time I installed Unreal Engine at all though, I did a google search and found some instructions for how to install it on Ubuntu. I don’t think you need special instructions now but you need to trace back through you steps and make sure you followed everything. It would help a lot if you told me what instructions you’re following or if you are not. I need a lot more info to help you if you want me to walk you through it.

I’m not sure exactly what I did before but this is what I’m going to do now

$ cd Documents/Builds
$ git clone https://github.com/EpicGames/UnrealEngine.git
$ cd UnrealEngine
$ ./Setup.sh
$ ./GenerateProjectFiles.sh

make ShaderCompileWorker UnrealLightmass UnrealPak UE4Editor

navigate into the Engine/Binaries/Linux folder and run ./UE4Editor

I know I’m probably missing something though

Are you on this page? A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

There are certain things you need to do especially if this is a first time setup.

$ git clone https://github.com/EpicGames/UnrealEngine.git
$ # or if you are using ssh authentication:
$ # git clone git@github.com:EpicGames/UnrealEngine.git
$ cd UnrealEngine
$ ./Setup.sh
$ ./GenerateProjectFiles.sh

That should do it and it looks like your building from the UnrealEngine directory. Are you still getting errors?

Also, it looks like your using the regular stable branch which may give you an old version. If you want a later version like me, use this line as your first line:
$ git clone -b 4.15 https://github.com/EpicGames/UnrealEngine.git

$ # or if you are using ssh authentication:
$ # git clone -b 4.15 git@github.com:EpicGames/UnrealEngine.git

so after I do the make step, I get this

ERROR: UBT ERROR: Failed to produce item: /home/yousaf/Documents/Builds/UnrealEngine/Engine/Binaries/Linux/libShaderCompileWorker-Slate.so
Total build time: 202.32 seconds (Local executor: 0.00 seconds)
Makefile:383: recipe for target ‘ShaderCompileWorker’ failed
make: *** [ShaderCompileWorker] Error 5

So I’ve been following the stuff mentioned here (skipped the dependency part since I’m pretty sure I already have all of that)

I’ve been able to make everything up to the editor so far. For some things it didn’t fully make the first time but it did the second time. Sometimes I would get errors in the middle of the make procedure but it wouldn’t stop the procedure but then other errors would. Not sure if this is normal.

Now just waiting on the editor to compile.

so I still end up with this same error

ERROR: UBT ERROR: Failed to produce item: /home/yousaf/Documents/Builds/UnrealEngineOLD/Engine/Binaries/Linux/libUE4Editor-Engine.so
Total build time: 2188.62 seconds (Local executor: 0.00 seconds)
Makefile:188: recipe for target ‘UE4Editor’ failed
make: *** [UE4Editor] Error 5

The real error is somewhere earlier in the log. UBT currently does not break the build to allow all errors to be collected at once, but you need to analyze it to find the reason why the library cannot be compiled.

Run it with GDB like in the page I sent and post the results. I think the instructions for how to run it with GDB is near the bottom. Running GDB should tell you where its failing in the build process. I think it will output a core dump you can analyze to find out where its crashing during the build.

Okay I think I’ve narrowed the problem down

When running it from terminal I get this message in red before it crashes

[2017.05.06-01.05.45:691][
0]LogQoSReporter:Error: QoS API server
is not configured, no QoS metrics will
be reported.

If I run it like this ./UE4Editor -opengl3

It runs without crashing but there’s no lighting even after I build it and in the terminal I get this error

EE
…/…/…/…/…/…/src/gallium/drivers/r600/r600_state_common.c:801
r600_shader_select - Failed to build
shader variant (type=1) -1

So the issue has something to do with my graphic card?

So as it turns out, the issue was my graphic card. Just learned that AMD stopped releasing drivers for their slightly older graphic cards that were on Ubuntu 16.04. I have a radeon hd 6950. Can’t revert to an older Ubuntu. There are open source drivers available as well but they don’t work well for gaming related applications. I tried using them but opengl was still stuck at version 3.0. I tried using the -opengl3 option but then there’s no lighting.

So I’m basically screwed unless I can get my hands on another PC.

Sorry about your luck. Maybe you can just buy another card? I got my Nvidia card for under $200.

thanks HeavenlyGamesBoss, finally got everything working after getting an nvidia card

if anyone else runs into this problem, I would not suggest trying to make the AMD card work, I downgraded to ubuntu 14.04 just to use the older drivers and even that didn’t work (too many problems due to old or non-existent documentation)