Error when adding widget to screen

Hey there,

you could try something like this:

by using the IsValid node it checks if the widgets is already created, if so it adds it to the viewport, if not it creates it before adding it.

hope it helps :slight_smile:

First Image is the error I get when ending the level.
The widget does appear in game, but for some reason I still get this error.

Below is adding the widget in the third person character BP.

Gamemodes have already been set.

Unfortunately that did not work. It is giving me the same error.

One thing you could try would be to place this code in a HUD derived blueprint. You see those little monitor icons on these nodes? Those mean that they are purely aesthetic and should not be used anywhere that can affect gameplay. That generally means that you should take care of them from a HUD.

As for this specific error, it says “Accessed None” when it was trying to read the property. That means that the widget is not being created correctly. I think this may be an order of operations problem. Stick in in your HUD blueprint and see if that clears the problems up. If not, I’ll help you figure this problem out inside your character blueprint.