Error using SimplyUE4 plugin on compiling

Hi everyone, i`m installed Simplygon plugin to UE 4.18, on compiling in UE or Visual Studio 2017 i see error “Could not find definition for module ‘SimplyUE4’ (referenced via MyProject.uproject → SimplygonUE4.uplugin)”, please tell me how to fix this error?

I’m having the same issue. Did you manage to solve this problem?

Same here :frowning: And I guess it has something to do with installing 4.19

@gesar93 @RVillani I’ve tried every direct installation method I could find online (or think of) without success. I’m going to install a binary 4.18.3 engine, install simplygon from the marketplace, and then copy the plugin directory into my source engine. Though I haven’t tried this, I wanted to let you both know this might be a solution in case I can’t get to it for another week or so.

I found a fix! You need to go to ProjectName/Source/ and backup ProjectNameEditor.Target.cs somewhere. After backup, delete it. Now you are able to “Generate Visual Studio project files” and open your ProjectName.sln

In visual studio, build once. It should throw you some errors. Now go to ProjectName.uproject and remove from plugin list SimplygonUE4. Now go to Source/ProjectName/ProjectName.Build.cs and you should be able to find “SimplyUE4” at the end of the PublicDependencyModuleNames. Remove it from there too. Build once more, the game should try to open without editor and throw you an error.

Close Visual Studio (and save your changes if they are not saved). Now place your backup of ProjectNameEditor.Target.cs back into ProjectName/Source/ and open ProjectName.uproject :slight_smile:

The editor will load and Visual Studio should work again too. Those are the steps that fixed it for me. Good luck and I hope I was able to help you! Take care! <3

I think it has something to do with the Simplygon UE4 installer program.

When selecting 4.17 as the engine it will add a folder named “NotForLicensees” into \Engine\Source\ThirdParty which is needed to build the binaries.

When selecting 4.18 as the engine, it adds a folder named “SimplygonUE4” into \Engine\Plugins which seems to be missing the source files. The engine will try to build all the plugins in the \Engine\Plugins folder, it errors on the Simplygon plugin due to the missing source files.

I was building 4.19 and the engine uses something new for LODs besides Simplygon (I seen something in the release notes “New: Proxy LOD System (Experimental)”). I deleted the SimplygonUE4 folder and the NotForLicensees folder and it built with no problem.

If you want to use Simplygon in 4.18 delete the SimplygonUE4 folder from the \Engine\Plugins folder and then select 4.17 in the Simplygon UE4 installer program. I built 4.18.3 release with no errors and when running a project, I did a search, in the log and found → Initialized with Simplygon 8.2.352.28

I haven’t tried Simplygon with 4.19 because I want to look into the new LOD system. And I’m not sure they will play nice with each other.

Hopefully a Simplygon update will fix the issue so there are source file included with the 4.18 plugin.

I installed version 4.17 from the “Simplygon UE4 Installer” into version 4.19.0 Release and it built with no errors. It shows in the editor log as loaded and I tested it on a skeletal mesh.

Thanks for sharing your fix, but unfortunately this didn’t work for me - I get the same error whilst trying to generate the VS files. Anyone have updates on why this could be? What version are you on?

Very quick fix

When I want to package and it gives me the SimplyUE4 module error, I just cut the folder SimplygonUE4 from [engine installation]/Engine/Plugins and copy it elsewhere. After packaging is successful, I just cut and paste it back there.

This way Unreal stops trying to find its source for compilation. And it won’t make any difference in packaged game, since Simplygon is an editor-only plugin (all of its modules are of type “Developer”).

Using 4.19. And this problem only happens when packaging a plugin, never the whole project.

1 Like

For those still stuck with the missing sources issue regarding 4.18 and 4.19 when using “SimplygonRedistUE4.exe” of the SimplygonSDK, Simplygon appear to build just fine with the UE 4.18 source version using the integration proposed on this Github repository :

This may perhaps solve the issue for the 4.19 as well since “SimplygonRedistUE4.exe” is also missing the sources for this version, quite the same way than for the version 4.18…

For the 4.18, just replacing the “Engine/Plugins/SimplygonUE4” folder with their 4.18 “Standard” branch version does the trick. Then launch the editor of a game project, activate the plugin in the editor and restart it.
This time it will again complain with missing dlls, but will manage to successfully build them right away, instead of failing as usual. The editor launchs right after with the plugin properly activated.

They also propose an “Advanced” integration option for 4.19, but next time I will try their “Standard” 4.19 first, since the method is already valid for 4.18.
They are also stating that the “Advanced 4.19” has some tweaks in the engine itself, somehow out of the Epic regular official depot’s scope at least for the moment.

I had the same problem.
Just as you know github

Go to “Plugins / SimplygonUE4 / Source / SimplyUE4” folder and install it.
By comparison, I did not have a “Source folder” in the files that “Simplygon UE4 Install” installed.