Error_UnknownCookFailure on Linux with a known-working project from Windows

I have a project that I copied from Windows and I’m just trying to build it and package it in Linux (Ubuntu 17.04, hooked into CodeLite). It compiles and runs in the editor just fine, but now I’m trying to package it up so that I can test network functionality, and unfortunately I run into an unknown cook failure. I do see a lot of errors for “can’t find file” and then it points to a file in the Third Person Shooter Kit from the Unreal marketplace. I imported some but not all of that project so that I could use its animation offsets and such. It worked in Windows, so even if there are errors there, none of them bother the actual execution of the game logic from the default level. Because the log is so huge, I broke it up into three files, and hopefully that gets past the file size limitations on this site. Part 1 is attached.

part1

part2

part3

Hey gamelord12-

When you say that you imported files, was this done while the project was on Windows or after copying to Linux? Can you right click the Content folder in the Content Browser and select the “Fix up Redirectors” options and try to package again? Additionally, if you’re already using the project on windows, you can cross-compile for Linux without having to copy the project to Linux. The steps to cross-compile can be found here: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

Cheers

Doug Wilson