Error trying to upgrade C++ project to new version of Unreal (4.15)

I’m trying to update from 4.14.3 to 4.15.1, but having problems with the Hot Reload.

I’m having the following error:

CompilerResultsLog: Info ERROR: Couldn't find target rules file for target '-canskiplink' in rules assembly 'UE4Rules, Version=, Culture=neutral, PublicKeyToken=null'.
CompilerResultsLog: Info Location: C:\Program Files\Epic Games\UE_4.15\Engine\Intermediate\Build\BuildRules\UE4Rules.dll
CompilerResultsLog: Info Target rules found:
CompilerResultsLog: Info     UE4Editor - C:\Program Files\Epic Games\UE_4.15\Engine\Source\UE4Editor.Target.cs
CompilerResultsLog: Info     UE4Game - C:\Program Files\Epic Games\UE_4.15\Engine\Source\UE4Game.Target.cs
CompilerResultsLog: Info     UnrealHeaderTool - C:\Program Files\Epic Games\UE_4.15\Engine\Source\Programs\UnrealHeaderTool\UnrealHeaderTool.Target.cs

It is compiling fine in the Visual Studio, and also creating new classes, but the Hot Reload is always giving this error message.

I already tried deleting Binaries and Intermediate folders and Regenerate Visual Studio project files, also Rebuild project from Visual Studio, but nothing is working.

same error, did you find a solution ?

Not yet.
I decided to wait to try to upgrade when the 4.16 version comes. I am seeing a lot of users having problems to upgrade to this new version, so I hope Epic solves those problems :frowning:

Finally, I found a solution in my case:

XXX.Target.cs in your source code:
Where XXX MUST BE the name of the project name
Due to a clone operation, it was different.

Hi Andre,

Is this still an issue for you? Would you be able to provide any more information about when you see this happening?

  • Are you using the binary version of the Engine that is installed by the Launcher, or did you build the Engine from source code?
  • Does this only happen in your project, or do you see the same issue occur in a new test project?
  • What process did you use to upgrade your project to 4.15?
  • What edits are you making to your code prior to starting a Hot Reload?
  • How do you start the Hot Reload?

I didn’t tried to to this again.
I am using the Binary version of the Engine. I tried to create new projects with the 4.15.1 version, but had another problems.

With this version the further I reached was this attempt and had this problem with the Hot Reload. In other tries I coudn’t even open the project.

To upgrade from the 4.14.3 to the 4.15.1 version I just opened the .uproject with the new version and upgraded locally, in the same project.

It was Compiling successfully in the Visual Studio, but showing this error message when I’ve tried to Compile with Compile Button from the Unreal Engine.

In general, this was the only problem I’ve got in this attempt, but I decided to continue with the 4.14 version a little longer until the 4.16 maybe, to avoid other problems.

I tried upgrading a 4.14 project made with the Binary version of the Engine to 4.15, and still did not see any issues related to hot reloading. Would it be possible to get a copy of the project that is giving you trouble so I can try upgrading that specific project? Also, are there any plugins that you are using in your project?

We tried again and same errors. Using no plugins.
I upload a ZIP with the project if you wanna try.
I appreciate if you can help.

Hi Andre,

I am very sorry for the delayed response to this post. Thank you for providing the sample project that you did. I was able to reproduce the issue that you described, and I believe the issue is actually a result of the name of the project. Version 4.15 included our initial support for the Nintendo Switch platform, and 4.16 included full support for that platform. If you are able to change the name of your project to something else, this issue should go away.