Error to package to Android

Hi guys!

I did some changes and the package for Android (All) crashed. Package for Windows 64 keep working and launch for both systems too.
The displayed error in the log is:
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: [javac] Compiling 68 source files to C: \ Users \ Wagner \ Dropbox \ soul \ LeapBiblioteca \ Intermediate \ Android \ APK \ bin \ classes
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: [javac] C:\Users\Wagner\Dropbox\Alma\LeapBiblioteca\Intermediate\Android\APK\src\com\YourCompany\LeapBiblioteca\ integer number too large: 3498571468
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: [javac] 3498571468 // the length of the file in bytes
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: [javac] ^
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: [javac] 1 error
MainFrameActions: Packaging (Android (All)): UnrealBuildTool:
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: BUILD FAILED

Attached follows the complete log.
Any suggestions?

Try to check, what is on the 20th line in this file: C:\Users\Wagner\Dropbox\Alma\LeapBiblioteca\Intermediate\Android\APK\src\com\YourCompany\LeapBiblioteca\

Hi Sojka,

Follows the file contents with the line 20 highlighted:

package com.YourCompany.LeapBiblioteca;

public class OBBData
public static class XAPKFile {
public final boolean mIsMain;
public final String mFileVersion;
public final long mFileSize;
XAPKFile(boolean isMain, String fileVersion, long fileSize) {
mIsMain = isMain;
mFileVersion = fileVersion;
mFileSize = fileSize;

public static final XAPKFile] xAPKS = {
new XAPKFile(
true, // true signifies a main file
“1”, // the version of the APK that the file was uploaded against
**3498571468 // the length of the file in bytes

This is fixed in 4.9. You can get the fix from GitHub here:

Chris Babcock,

The error persists with 4.9.0.

Wagner Dias,

Sorry about that; I read the question too quickly before and didn’t check the actual length of the file, just the error message. Expansion files are limited to 2 GB and you are trying to use about 3.26 GB. Make sure you have “Create compressed cooked packages” checked in Project Settings - Packaging in the Packaging expanded section.

I tried, unsuccessfully:

  1. “Create compressed cooked packages”
  2. Reduce the textures size.
  3. Remove unnecessary items.
  4. Build configuration as “Shipping”.

Only works when I created a new project and migrated the content from original project.