Download

ERROR: The following files are set to be staged, but contain restricted folder names ("Switch"):

I am following the video lesson on unreal academy " AEC Blueprints ", and when I try to pack the game it gives me this error:

UATHelper: Packaging (Windows (64-bit)): ERROR: The following files are set to be staged, but contain restricted folder names (“Switch”):

I tried to search the net but I did not find a solution.

How do you remove a restriction from a folder?

Thanks to those who want to help me.

2 Likes

Unreal has many hidden rules it never tells you about until it’s too late, and it has the most restrictive rules on naming I’ve ever seen in a modern system.

CAD software, comparatively, has none of these rules (because most companies invent their own more or less restrictive naming conventions for use in their own PLM/PDMs).

I’m guessing you’re not allowed to name a folder Switch, because of the Nintendo Switch. Rename that folder to something else, and the build may work. :slight_smile:

4 Likes

I do not believe it! I don’t know why I didn’t think of it!
I didn’t want to break all the links, but actually changing just the name of the folder doesn’t change anything!

Thanks a lot, it works perfectly!

1 Like

Thanks a lot @roberteker . I was facing same issues but with name of folder set to “Windows”. I used it for the windows of a house model. Renamed that and it worked.

1 Like

Actually it does.
I had the same result that it was still not working after renaming. All you have to do after rename, is to restart the engine and you can start packaging your project.

I guess that even if you rename the folder, the original name is still in memory and needs to be cleaned up first.

Maybe a “fix redirectories” could also do the trick, but i did not checked that.

2 Likes

Thanks it work brother. i have problem that name “windows”. when i rename it then it worked

1 Like

Older thread, but top google result.

Fmod contains a folder /desktop. The project I’m trying to build now is whinging about that. Problem is FMOD insists on that folder name. Also, I have the same folder in another project which is also included and yet I’ve built it dozens of times without it complaining. There must be more to it than that.