Error that is no error causes trouble

Sorry, it’s me again! Everytime I load up my apparently [bug-ridden project][1] I get this error in an actor blueprint where its triggering an event in my gamemode blueprint:


Despite the name of the event, the COMGamemode variable gets set inside the gamemode blueprint before this event gets fired from inside the actor, so this should be a valid communication between two blueprints. Once I click compile, the error disappears and the project works as expected.

Apart from a minor annoyance, this causes the packaged or via “standalone game”-played project to NOT work correctly, even after compiling the blueprint.

I even tried not using the COMGamemode variable and using casting instead. The same happens when I do that.

There’s also this other error: After playing I get a single “Accessed None” error of a variable that is completely unrelated to the node the error message references. When I delete that node and recreate it, the error picks another unrelated node.

Everything works fine despite the existence of this error. It’s just a tad annyoing.

4.1 solved the first problem. Thanks, guys!


Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you.