Error System Keychain on the remote Mac

Hi, Ok so im getting and error massage that says:

PackagingResults:Error: Error Failed to sign executable. Make sure your developer certificates have been installed in the System Keychain on the remote Mac.

So let me tell you what i have done. So i just restored my mac to factory start because i was having issues with it. So i reinstall xcode and add my dev account to it. I made new certificates and provision with .p12 as well. I then copied the certificates and key to the system in the System Keychain.

Then i put the new ones into the editor in unreal. So i followed all the steps and look up this issue in answerhub and im doing everything right. But when i go to package it i get this error. I cant seem to fix it so i need help. Hope you can help, Thank you for your time and have a nice day.

p.s here is the log to see.

link text

Hey Snowynight,

There is a known issue related to this. You can follow the progress of the issue as it moves through the developers, here:

There is also a couple more issues related to improving the remote building system as a whole.

There is a work around figured out by another user. You can follow it in this thread:

Thank you, hope it gets fixed soon.

Im still getting the same error.

link text


Have you tried manually rebuilding iPhonePackager, DeploymentInterface and MobileDeviceInterface?

Yes i have tried that still nothing get the same error.

Did you make sure to: PackagingResults:Error: Error Failed to sign executable. Make sure your developer certificates have been installed in the System Keychain on the remote Mac?

I did put it in System Keychain. still have the same error.

Please make sure that you completed these steps to ensure you’ve set the Mac up properly to accept remote building:

  • Open the System Preferences > Sharing on the Mac machine
  • Check the Remote Login checkbox
  • Open System Preferences > Networking
  • Open Keychain Access
  • Select System from the left hand menu
  • Select Certificates from the left hand menu
  • Select one of the installed certificates
  • Right click on the certificate and select Get Info
  • Expand the Trust options
  • Set When using this certificate: to Always Trust (setting this will all of the sub options)

Did every step, the only one that was not done prier what the Always Trust. Now it is set to always trust but im still getting the same error.

Have you upgraded to 4.14 yet, and tried the same steps there?

UATHelper: Packaging (iOS): UnrealBuildTool: No signing certificate "iOS Development" found:  No "iOS Development" signing certificate matching team ID "BE2WVFER98" with a private key was found.
UATHelper: Packaging (iOS): UnrealBuildTool: Code signing is required for product type 'Application' in SDK 'iOS 10.0'

Please double check that the certificates are installed on BOTH computers. Double check, it’s very easy to mix up certificates, or forget to update them as necessary.

Make sure it’s being signed for iOS development on the certificate as well. If you don’t have one that matches, or one that isn’t a wildcard, then you’re going to run into trouble.

Ok I’m slowly narrowing down the problem. Ok so when I use my ios development certificate and provisions ever thing works fine. But I can’t submit it because you need to use distribution certificate and provisions for that.

So when I use the distribution ones that’s where I get the problem. so i decided to see what the problem is because when I add the distribution ones in the unreal settings it gets add but I wanted to see if there is a problem so I used the IPhonePackager.

When I do that that were I see the problem when I try to add the distribution ones I get an error. Could not find file ‘C:\Program Files\Epic Games\4.14\Engine\Build\IOS\UE4Game-Info.plist’.

When I look up that problem it says its a problem with the bundle info don’t match but mine match they are the same I don’t know that to do this problem has been going on for far too long.

It’s been a while since we last spoke with you. Could you please upload screenshots showing your bundle ID matches? Which version of the engine are you working out currently?

Thank you!

Ok here is a screen shot showing they match. I’m also working with 4.14.

I believe you need to check which keychain is in your certificate on the mac, please review this AnswerHub post.

I have seen that post before, that is not the problem I’m having. My problem is on the PC side of things. When using IPhonePackager to import my distribution certificate and provisions i get this error, “Could not find file 'C:\Program Files\Epic Games\4.14\Engine\Build\IOS\UE4Game-Info.plist”.

Your key in the screenshot says Distribution while the error is saying Development. Are you positive that you’re packaging your project under the correct settings? If you package for Development, you’ll need Developmental provisions.

I set it for Distribution. here is a screenshot of my project settings to show you.

If you have it set up for distribution and it’s still calling development in the logs, make sure that you’ve deleted the Intermediate folder and Save folder and reset it to distribution and shipping. Make sure that the correct provisions and certificates are being used.

You might need to remove and reinstall your certificates and provisions for the engine. It’s possible that the engine is picking up the wrong set.

Do you have any newer logs you can upload as a .txt file?

Thank you!