Error running ./UE4editor on Ubuntu 18.4.4

I followed these instructions : Linux Quick Start | Unreal Engine Documentation to section 4 - Running UE4 on Linux step 2
On running console command ./UE4Editor I get the splash screen and this error message

[2020.05.19-10.54.19:795][ 0]LogInit: Using SDL_WINDOW_VULKAN
: CommandLine Error: Option ‘help-list’ registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options

Any help would be appreciated.
** Tracked issue to the mesa drivers. my mesa drivers updated 2020/06/21 UK following this I recompiled and the editor managed to build the shaders and load the editor window. Display is still messy (Desktop Icon corruption) but it appears to be working. I haven’t managed to work through the mesa build instructions to build mesa from scratch. I can’t say what library was breaking the build. hope this helps.

I downloaded the zip version of the code.

Downloaded rebuilt same error.

Built 4.25 using git same error. I don’t know enough about the code to track this down. I don’t have LLVM installed which searches suggested might be the cause. Can anyone tell me how to built or run UE4Editor in debug?

You can run the editor with the “-opengl3” switch to force the editor to run using OpenGL instead of Vulkan.

BrilliantOne, Thanks for the suggestion. I read somewhere in the docs that 4.25 doesn’t support open gl on Ubuntu, only Vulkan. I tried your suggestion and I got an error “Trying to force OpenGL RHI but the project does not have it in TargetedRHIs list”
Thanks for taking the time to reply.

One other thing that I can think of is that depending on your video card, you will need to ensure that you are using proprietary (closed sourced) video drivers. For example, if you have a NVIDIA video card, down and install the drivers from the NVIDIA website.

I have the same issue, and I am using the proprietary drivers for my Radeon RX480. Lubuntu 20.04 LTS btw.

How did you track the issue to mesa drivers? Based on the LLVM ERROR, and some googling, I thought the issue would be related to use of incorrect libraries at link time.