Error packing project - Directory NotFoundException

So I’m trying to package a demo of my game. I duplicated my project, changed the name by appending DEMO after and made the necessary adjustments to my content so the demo only includes one level. Everything works fine until it comes time to package the project. The packaging ends with “Uknown Error” and when I look at the output log and show only messages and then filter for the word error I get the following messages:

MapCheck: Info Map check complete: 0 Error(s), 0 Warning(s), took 89.743ms to complete.
LogTemp:Display: IPP ERROR: Application exception: System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Users\PeterComp\AppData\Local\Apple Computer\MobileDevice\Provisioning Profiles'.
LogTemp:Display:    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
UATHelper: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception: System.ArgumentException: An item with the same key has already been added.
ble`1 Distribution, Nullable`1 Prebuilt, Nullable`1 RunTimeoutSeconds, String SpecifiedArchitecture, Nullable`1 IterativeDeploy, Nullable`1 FastCook, Nullable`1 IgnoreCookErrors, Nullable`1 RunAssetNativization, Nullable`1 CodeSign, Nullable`1 TreatNonShippingBinariesAsDebugFiles, String Provision, String Certificate, ParamList`1 InMapsToRebuildLightMaps, Pa
UATHelper: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)

The weird this is that the first error “DirectoryNotFoundException” is mentioning something to do with Apple and MobileDevice but I’m packaging for Windows X64.

Also there’s the message “An item with the same key has already been added”. I thought this was referring to the ProjectID that is generated but I’ve generated several new ones and nothing helps.

Oh, I finally got it working. I deleted the Intermediate and Saved folders in my project directory and it packaged fine after that. Very strange but hey, it works so I’m happy.

The same for me it solved the problem

The same for me it solved the problem

very useful answer

did not solve for me, i deleted folders yet i cant build any new project or any at all? same error please help