Error packaging: need visual studio 2017

I have had this error in 4.25 and now in 4.26.
The compilation works just fine but when it comes to packaging, it fails and says i need visual studio 2017. Note that I have never used VS2017 on this machine. I even tried to install it but VS2017 lacks the appropriate windows 10 patch to package anyways.

This is the error:

UATHelper: Package Plugin Task (Windows): Building plugin for target platforms: Android, IOS, Linux, LinuxAArch64, Win64, Win32
UATHelper: Package Plugin Task (Windows): Running: C:\Program Files\Epic Games\UE_4.26\Engine\Binaries\DotNET\UnrealBuildTool.exe UE4Game Win64 Development -Project=C:\Users\Yersinia\Desktop\TopDownPhysicsCamera\TopDownPhysicsCamera\HostProject\HostProject.uproject -plugin=C:\Users\Yersinia\Desktop\TopDownPhysicsCamera\TopDownPhysicsCamera\HostProject\Plugin
s\TopDownPhysicsCamera\TopDownPhysicsCamera.uplugin -iwyu -noubtmakefiles -manifest=C:\Users\Yersinia\Desktop\TopDownPhysicsCamera\TopDownPhysicsCamera\HostProject\Saved\Manifest-UE4Game-Win64-Development.xml -nohotreload -2017 -log="C:\Users\Yersinia\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.26\UBT-UE4Game-Win64-Devel
**UATHelper: Package Plugin Task (Windows):   ERROR: Visual Studio 2017 must be installed in order to build this target.**
UATHelper: Package Plugin Task (Windows): Took 3.1105121s to run UnrealBuildTool.exe, ExitCode=6
UATHelper: Package Plugin Task (Windows): UnrealBuildTool failed. See log for more details. (C:\Users\Yersinia\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.26\UBT-UE4Game-Win64-Development.txt)
UATHelper: Package Plugin Task (Windows): AutomationTool exiting with ExitCode=6 (6)
UATHelper: Package Plugin Task (Windows): BUILD FAILED

I scoured for answers but unfortunately did not find any good ones. I did find this answer but I do not understand what has to be done in order to make it use VS2019 instead of VS2017:
[Need VS 2017 to build plugins in 4.25? - Programming & Scripting - Unreal Engine Forums][1]

I have heard from some folks to use the cmd line and pass it but I have no idea what they are talking about.
[1]: Need VS 2017 to build plugins in 4.25? - Programming & Scripting - Unreal Engine Forums

I managed to package in one project by reinstalling VS2019 and VS2017. Now it worked for that one project and the log files are quite yiffy. Sometimes it uses VS2019, sometimes it uses VS2017. It’s a mess.
In another project however, the android platform is causing issue, even though it is blacklisted on the .uplugin…

Im experiencing the same issue with the blacklist not working, have you ever solved this?

Yes, use the whitelist only instead and take out android.

1 Like

Thanks for the reply. For me however it’s still compiling for other platforms :confused:

For me the issue was solved when I installed Build Tools for Visual Studio 2017 from here: Visual Studio Older Downloads - 2019, 2017, 2015 & Previous Versions (