Error Packaging my Project, "Ensure condition failed: BP->bCachedDependenciesUpToDate "

Hey guys, I put "Ensure condition failed: BP->bCachedDependenciesUpToDate " in my title because that’s the closest thing I could find to some kind of error in the UAT_Log.txt, but I’m not very experienced at looking through those files.

I’ve been trying to deploy to Windows 64 bit, and the errors I’ve got prior to this have been the average blueprint compile errors, and a few times the editor was tripping up on uassets that were in the files, but not showing up in the editor, so I deleted them manually. Now I’m having issues finding out what’s going on. bCachedDependenciesUpToDate just looks like some bool you can declare in the blueprint editor, so I don’t think that’s what’s causing the packaging error, and I’ve been looking at this UAT_Log.txt file so long that it’s all starting to blur together, and I’d appreciate some fresh eyes.

[Here is the cook file,][1] and [this is the UAT_Log.txt file.][2]

I also recently updated to 4.18 from 4.15, which was a bit of an ordeal, but I don’t think that would have anything to do with the packaging error, but it might be worth mentioning. Anyway, thanks in advance for checking out my question, let me know if there’s any other info I can provide to help you out.



I’ve got some more info after some looking around. [This is the Ensure][3] that trips the error in my packaging, it directs to the Unreal Engine Source github, which requires you have your github linked with your Unreal account. If you don’t want to do that, this is the short of it:

// The only known way to cause this ensure to trip is to enqueue bluerpints for compilation
// while blueprints are already compiling:
			if( ensure(BP->SkeletonGeneratedClass) )
			for(const TWeakObjectPtr<UBlueprint>& Dependency : BP->CachedDependencies)
				if (UBlueprint* DependencyBP = Dependency.Get())

EDIT2: Ignored the problem hoping it would go away and it hasn’t. I’m afraid to go further with my game in case something needs to be re made and it involves a lot of backtracking. Here’s a list of errors that appear in the output log:

[1]:228573- [2]: 228574-uat-log.txt (546 KB)

This still isn’t solved. Here’s all the errors that are highlighted in output so you don’t have to search for them in the text document:

Hi all.

Same problem here.

“Ensure condition failed: BP->bCachedDependenciesUpToDate [File:D:\Build++UE4+Release-4.18+Compile\Sync\Engine\Source\Editor\Kismet\Private\BlueprintCompilationManager.cpp] [Line: 1467]”

Any solution ?

Ok I finally found a solution to my problem.

In my project, the problem came from a Blueprint Interface I added a few days ago. I tried to delete it and recreated it and now it finally works. Hope this will help !

Getting the same error on 4.19 when trying to pack the project. Anyone has a better answer? :confused:

Did you manage to get to the bottom of this issue? I’ve come across it in 4.21.2 and cant for the life of me figure out whats going on

I got more than 56 erros when trying to package 4.27.2