ERROR packaging for Android using UE 5.4.2 with "Mobile Location Services - Android" plugin enabled?

Hello everyone,

I am facing difficulties when packaging my Android app with Unreal Engine 5.4.2 while having the “Mobile Location Services - Android” plugin enabled (along with all dependencies and permissions). Packaging the project on 5.3.2 using the plugin works fine.

Packaging Error log (5.4.2): eroare - Pastebin.com

If anyone is able to test if packaging for Android works on UE 5.4.2 while having “Mobile Location Services - Android” plugin enabled that would greatly help to determine whether this is a bug or user error.

Many thanks!

I just created a brand new 5.4.2 project from 3rd person template. Mobile location services for Android plugin was enabled by default. Packaging for Android took longer than expected, but completed without any error.

There’s and old example project for getting location data, will try if I can package this and get it to my Android phone.

Edit: Trying to implement location services of my project that worked yesterday, but now I am getting the same error :frowning:

Thank you for your prompt reply, OrbitalZones!

As of right now I understand you are experiencing the same behavior when packaging for Android using the plugin mentioned above. Does the error have the same text or very similar to the pastebin link?

I will wait for a few more replies, if they will come, and if they happen to confirm the same result I will file a bug report.

It is exactly the same error message (GameActivity.java:729: error: cannot find symbol), apart that on my PC the script will mount drive name Y: , because Z: is already used.

Also I can confirm that packaging is working again as soon I disable the plugin.

1 Like

Same issue with UE 5.4.2 when packaging with enabled mobile location services Android plugin on mac:

UATHelper: Packaging (Android (ASTC)): /Users/…/Documents/Unreal Projects/UE54BLANK/Intermediate/Android/arm64/gradle/app/src/main/java/com/epicgames/unreal/GameActivity.java:731: error: cannot find symbol

Thank you for also testing this direction, I was curious if the iOS version worked. I had filed a bug report and I will update this thread if anything happens.

Thank you for your help!

Be aware this is not related to location services for iOS. It is still for Android, but when packaging on Unreal for macos. Thanks for adding this to your bug report.

Okay, 5.4.2 definitely throws this error when packaging for Android!

Z:\app\src\main\java\com\epicgames\unreal\GameActivity.java:729: error: cannot find symbol
UATHelper: Packaging (Android (ETC2)):             activityContext.runOnUiThread(new Runnable()

Solution: disable Mobile Location Services for Android! LOL

no way, i wasted 3 days to fix it , i thought it was something wrong with jdk, thx man

Hello: Please desable plugins in your projects.

Android Media Player (Plugins Disable)
Android Android Movie Player (Plugins Disable)

If after this it still doesn’t work, then disable the next plugin Android FileServer (Disable)

Thanks

Hello Rovmit,

Thank you for your reply!

Quick recap: I am working on UE 5.4.2, project packages fine until I enable “Mobile Location Services - Android Implementation” plugin.

With that plugin enabled I had disabled Android Media Player and Android Movie Player. The packaging failed with the same error as in my initial post.

After this I had also disabled Android FileServer plugin, unfortunately the packaging failed with the same error.

Can you confirm that version 5.4.2 of Unreal Engine, while having Mobile Location Services for Android enabled, is able to package without errors on your end?

Thank you.