Error opening map file!?

“Failed to open map file. This is most likely because the map was saved with a newer version of the engine.”

I have spent a long time using UE4 and for the second time on my second project, it is saying that my map is unable to open because is is probably saved with a newer version of UE4.

This is the second time this has happened. Losing projects is no error that should be ignored by the developers and I am shocked this is even happening! I have every right to be angry and upset if my project that I have been at hard work is has just gone for no reason.

Extra info - I have tried using a backup map which does work but some of my blueprints are missing. However, when I look in my documents and in the project folder, the blueprints are there.

None the less, this shouldn’t happen and definitely not after 3 huge updates. So far with UE, not good. If you know a permanent fix for this then I would be very greatful as moving to another engine is not want I want to do. UE4 is great, when it works! :L



No one at Epic has anything to say about his? Not even some advice?

I heard about this bug several times and I think many of them solved it with updating the engine to the latest version of the UE4 :slight_smile: Btw, which version do you use? Have you already tried to open it in another project (copy everything into the new project and try to open it there)

I think epic games have already seen your post → it just takes some time until somebody answers, because some problems are really hard to solve :wink:

When you need a fast reply you can also post your question into the forum, because there many people from the communtiy are active.

I am just having problems with importing the uasset file into the engine. The map now correctly opens, however the “MyProjectile” and the “MyCharacter” blueprint had literally disappeared and I’ve tried everything to import it.
Why does UE4 not let you import their own frickin’ asset files. It is just an absolute joke! Thank you for the answer though :slight_smile:

Hi Kevin,

No need to import them. You can either migrate them over or just copy them into the Content folder through Windows Explorer.


I don’t think the situation is being grasped properly. I have tried what you have suggested and much more as I’ve mentioned in the post. Placing the file in the folder does not do anything (When i got to the project, the blueprint is still not there even when i put it in the file)