Error on laser reconstruction


when I try to reconstruct mesh from laser data I get an error: “Processing failed: invalid or corrupted data”  with RC version. With old version ( RC) everything worked ok.

Could you help me on this?


After new investigations it seems that the problem is due to a failed sampling on a single lsp.

It is strange that sometimes the software adds a bad sampled result and sometimes it doesn’t add a lsp at all.

Hello Alessandro,

thank you for reporting the issue. Would it be possible to share with us that one laser scan that is not sampled or loaded correctly? If this is a problem on our side and we can reproduce it, we will be able to fix it. If yes, you can send us the download link via contact form on our webpage with a reference to this post. Thanks a lot.

Hello Zuzana,

ok we will try to isolate the failed sampled data and we will send you (next month) the link.

Thank you


How did you find the corrupt lsp file? I am having the same issue when I try reconstruction on scans using RC version. I get the same error that you did… “Processing failed: invalid or corrupted data”. I have seen other reporting the same issue, but not resolve that I know of. 

We found that the corrupted lsp file was the only one without no points in it (checking every lsp on the list inside 1-D View). This sounds a little strange because we thought RC deletes a cube face without points.

We are trying to isolate the file for inspection (busy period).