Error on editor launch UnrealBuildTool

UnrealBuildTool has stopped working, this error shows 4 times then the editor opens but my problem si when i try to right click on .uproject generate Visual Studio Project Files, then it shows this error and it closes does nothing.

I have this error from preview version when the 4.4.0 launched. If I try 4.3 … it is ok.

detailed erro when I click debug:

Failed to generate project files:
Unhandled Exception: System.Xml.XmlException: Root element is missing.
   at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
   at System.Xml.XmlDocument.Load(XmlReader reader)
   at System.Xml.XmlDocument.Load(String filename)
   at UnrealBuildTool.XmlConfigLoader.Load(String ConfigurationXmlPath)
   at UnrealBuildTool.XmlConfigLoader.LoadData()
   at UnrealBuildTool.XmlConfigLoader.Init()
   at UnrealBuildTool.UnrealBuildTool.Main(String[] Arguments)

If you need more details or even remote connection then let me know.

Ion

Hi Ion,

Are you using the binary version of the Engine installed by the Launcher, or did you build the Engine from source code? If you create a new project from one of the templates, do you see the same error?

Hi Tim, The engine is installed by the launcher and yes it is the same, even if I create a new project :(.

The system is 64 bit Windows 8 Pro.

It looks like one of your XML configuration files is formatted badly.

Do you have a BuildConfiguration.xml file in My Documents/Unreal Engine/UnrealBuildTool? Can you rename it to something else and try building project files again?

If you don’t have such a file, could you try repairing your installation from the launcher?

Sorry for the delayed response. I just wanted to confirm that this is a new issue for you in 4.4.1. This was not happening in 4.3?

Could you provide a screenshot of the error message and the exact steps you are following?

Sorry Ben but that didn’t work :(, I removed and it regenerated the xml file but still gives the error.Also reinstalled the version 4.4.1 on 4.3 it works fine. I also attached the error message that is recorded in windows logs, hope this helps.
[link text][1]

Is it generating a BuildConfiguration.xml file to your My Documents folder?

Can you check for a file with the same name in all the following directories and delete them if they exist?

E:/UNreal Engine 4/Instalat/Unreal Engine/4.4/Engine/Programs/UnrealBuildTool

E:/UNreal Engine 4/Instalat/Unreal Engine/4.4/Engine/Saved/UnrealBuildTool

(Your user folder)/AppData/Unreal Engine/UnrealBuildTool

(Your user folder)/My Documents/Unreal Engine/UnrealBuildTool

For what it’s worth, I’ve fixed this throwing an exception in our main branch. I can probably back-port it to the 4.4 build and issue a QFE for you if the steps above don’t work.

First question: no;
I checked and deleted the second and the third
But from appdata and mydocuments there is not such file.

Hi Ion,
could you please send us BuildConfiguration.xml files from those locations that the Engine generated?

Here they are. Hope they will help you, if you want let me know and we can establish a time of day and you can connect to my pc.
link text

One more thing. Could you look for additional file in the “(Your user folder)/AppData/Roaming/Unreal Engine/UnrealBuildTool/”?

link text

Not this is how it needs to be done on some systems: 1. Delete the xml build configuration from all the folders Instalation directory Programs and Saved then from appDataRoaming/UnrealEngine/UnrealBuildTool then restart the PC . Then go tu UE and open it solved the problem without restart it’s not working.

Yeah, your BuildConfiguration.xml from AppData/Roaming is definitely broken (at least the one you’ve sent). It looks like just a couple of NULL characters. It may be a bad write on you HDD or sth. Could you verify if the new one is with some XML format?

Is this problem still happening? Or after deletions and restarts its fine now?

Thanks,
Jarek

Thanks Jarek, everything is fine now.