Error on duplicate map

Hi all,
I simply want to duplicate a level/map. Then I get the following error message:

Can't save ../../../../../../Users//Documents/Unreal Projects/XXX/Content/XXX/Maps/test/Milestone03a.umap: Graph is linked to object(s) in external map.
External Object(s):
Try to find the chain of references to that object (may take some time)?

If I click “Yes”, then this is followed by this error:

The asset '/Game/XXX/Maps/test/Milestone03a' (Milestone03a.umap) failed to save.

Cancel: Stop saving all assets and return to the editor.
Retry: Attempt to save the asset again.
Continue: Skip saving this asset only.

If I click continue, the Editor displays the duplicated map, but strangehow not using the new name I gave it but the exact same name as the source map. Also there is not asset file on disc.
I am using Perforce for version control, the duplicated level is shown the branch symbol (

), which also does not make any sense to me.

There is nothing as the above mentioned external references, I searched the whole (hardly complex) project, searched the level blueprint. The reference editor also does not show anything like that. I tried a lot of things, renaming the source map, moving it to a different subfolder etc.

This is a real showstopper at the moment, I am quite desparate and cannot continue with that project.


I just don’t understand what that _C means. The map ist named “Milestone03”, there is nothing like an object “Milestone03_C” - does it have something to to with compiling is somehow under the hood? An why is is an “external reference”?

I now somehow found out just by trying and trying out serveral things. But don’t ask for sense…

In the Level Blueprint of the level you want to duplicate, got to Class Settings, under Class Options check Generate Abstract Class. Save level, now duplicate it. Error is not appearing anymore, but Editor crashes. Never mind, re-open and tada, duplicated map is there.

(Now undo the setting from above).

If someone has an explanation for that I that would be highly appreciated!


1 Like

This worked! I also have no idea why and how though. At least I can continue my work but I hope Epic fixes this soon. Happened to me on 4.22.2 in July 2019, more than one year after you posted the solution and seems it has not been fixed yet…

This did not work for me… I tried this but it just crashes without ever saving the actual level

Had a 4.25 project. Migrated it to 4.26, I’m running 4.26.2. Map, duplicate, crash. Sent crash to Epic. That’s it. Still happening.

This didn’t work for me either.

It’s really annoying (and unbelievable), that you cannot do something so simple as copy or duplicate maps, in order to have backups or do different variations of the same level. :frowning:

Here’s a convoluted solution, in case anyone finds this:

  1. Make a backup of the project, in case this all goes wrong.

  2. Go to the project’s folder in Windows explorer and find the maps. Duplicated the .umap file of your map by copying and pasting it onto the desktop.

  3. Open the project and in the Engine’s content browser: rename the current map, save and close the engine. (I’m not sure if you can rename the current map you have open, so you might need to open a different map first).

  4. Put the copied .umap file you created back in the folder in Windows explorer. Then open the project and bake the lighting for that map.