Download

Error Object has wrapping UVs.

Hello!
I’m using UE 4.9.1
I have imported a very big fbx model and placed it in the world, but “build lightind” has failed with an error “Error Object has wrapping UVs.”
How to repair it without editing a model?

You have to make sure the uv are not overlapping the normals should be on face and tangent space selected if you did not create this model yourself try importing it into blender or something and do the uv unwrap yourself to eliminate these errors.

BTW it helps if you show some screens.

Greetings,

It means that the specified light map coordinate has overlapping UVs. You can try fixing it by opening your static mesh in the viewer and using the auto UV tool (you can find that in the details panel). It should create the new UVs in channel 1 by default but you will have to change the lightmapcoordinateindex setting to match. :slight_smile:

Otherwise fix it in your 3d program -> http://www.worldofleveldesign.com/categories/udk/udk-lightmaps-01-basics-and-important-principles-for-creating-using-lightmaps.php

there’s a screenshot
Безымянный.jpg
this mesh isn’t small
how can i remove these polygons? they’re on exit
Безымянный.jpg

and message log
Безымянный.png

i think it’s made for using different UV channels for each element
Безымянный.png

how to use different UV channel for each element? there’re 897 elements

I think each element has overlapping uv’s otherwise you wont have this issue.

Better to build your own static meshes or try fighter’s tip.