Download

ERROR: Object has overlapping UV's!

So I have this problem. I’ve looked over the internet and even though I found a few articles about it, nothing seem to come close to me resolving this issues.

Anyway, I will try to give as much information as possible!

So first thing first I used UnwrapUVW on the object. Map Channel is 2nd just like it suppose to be. See image below

17758863e49dbdff96085f5f349599c1e6171875.jpeg

Now this are my options when I’m exporting to .fbx

13bf8f24381e352348314c78258ac6672a73140f.jpeg

This are my options when I’m importing to UE4

e30bfb0f17d9973433d1ef052bb8552c314bb4f3.png

Next, this is mesh properties inside the engine. I have it at UV Channel 1.
Although I’m not sure about lightmap resolution

Untitled-4.jpg

And last but not least, this is the error I get

Untitled-5.png

Need help, please :slight_smile:

P.S. Not sure if this was posted in right section of the forum!

Right now it’s using the UV channel 0 to bake lightmap which I guess it’s your texture channel. Set the lightmap index to 1 ( which is 2nd uv channel). Also I would recommend flattening it in max with a much higher angle , like 65-85. You have way to many uv islands for this kind of mesh.

I would go with a 256 lightmap resolution for it , maybe even 512.

You can ignore the overalapping error. Sometimes I even have close to 30% overlapping and the lightmap still bakes ok. It all depends on how the UVs are layed out.

Thank you for your respond. Sadly, still gives me that error. I used “70 polygon angle”. 0.015 Spacing.

This are the options in UE4 after I re saved .fbx file:

New_1.jpg

But the error still persist, I know I’m doing something wrong, just can’t figure out on my own :frowning:

New_2.jpg

Edit: I think I come to the conclusion that it is something to do with unwrapUV, not sure thou

Your mesh is far too dense, you should have used a lower resolution mesh because it really doesn’t need that many polygons.

Also, for a mesh like that you will not get good automatic flatten UV’s, but there’s a very easy solution. Since the mesh started out as a plane it had good mapping in the first place, you can see the grid pattern in your texture. That means it’s pretty much already mapped well. Since you added a shell modifier you just simply need to add a second UV channel in 3ds Max and then select the back side (might be as easy as selecting overlapping faces) and then separate the back from the front. It should be able to map out to two rectangle shapes.

In UE4, you can see in that screen the lower right hand side there’s the Static Mesh Settings section, that’s where the lightmap resolution is set (set to 64 which is too low), if you expand that section there’s also an option to set the UV channel that you will use for lightmaps.

That section above>Build< is the settings that UE4 uses if you allow UE4 to try and automatically generate lightmap UV’s, which is what you don’t want it to do.
There is no good automatic method of generating lightmaps, so you have to do it by hand to get the best results.

Thank you for the reply, I’ll try what you said! Hopefully I wont see that problem again :slight_smile:

As darthviper107 said you need to lower the polygon count on this. You can experiment with ProOptimizer modifier in 3ds max to get lower polygons without distorting the geometry.

Tried all that, still no luck :frowning: Now I get new error on top of what I already had!

new_1.png

Just to give you an idea what I’m working with, that is a free model from this website, here: http://www.viz-people.com/shop/3d-fabrics/
Hope that will give you more details on the model itself.

This is a common error which comes when your mesh is missing Channel 1 info or any channel you used for texture coordinates but the main thing is that it must have it’s mapping coordinates defined. Here I recreated this error for better understanding. To remove this error just add UVW Map Modifier/Recheck Generate Mapping coordinates in channel 1.

&stc=1

&stc=1

&stc=1

Interesting light setup you have there Raghu. Any new discoveries?

@Raghu Thanks man :slight_smile: