Error Message: Out of video memory trying to allocate a rendering resource


Recently, when I try to open UE4, I click my projects and after trying to load them, I get an error message which says:


Out of video memory trying to allocate a rendering resource.

I click OK, and it just closes the project…

Anyone have any ideas?

Thank you

Hi JHeller1,

Which version of the editor are you currently using?

Hi JHeller1,

We have not heard from you in quite some time. I am marking this as accepted for tracking purposes. If you are still experiencing this error, please comment back with the requested information. Thank you.

I was using 4.61, I went have to 4.51 and now it works again after updating my graphics card

Hi Jheller1,

I am happy to hear you found a solution that works for you. If you experience this again please comment with additional information. For now I will mark this as answered for tracking purposes.

Hello. I am expiriencing the same problem with version 4.7.2 . I just downloaded unreal engine so I am new in this, which means I don’t know how to go to a previous version.

Any suggestions for the video memory problem

Hi HenryG,

Have you updated your video card and/or video card drivers recently? Can you post your dxdiag here so I can take a look at it? To do so, go to your windows start menu and type “cmd” into the searchbar then select the command console program. In the command prompt window, type “dxdiag” and press enter. Then save this as a .txt file and upload it here. Thank you!

I have tried updating my video card drivers by following this video, but it says it has no update to make. My System information are :

OS: Windows 7 premium 64-bit(6.1, structure 7601)

by: Fujitsu

model : lifebook AH531

Bios: Default System Bios

Processor: Intel(R) Core™ i7-2620M CPU @ 2.70GHz(4 CPUs), ~2.7GHz

RAM: 8192MB

Paging File : 2368MB in use , 13838MB available

DirectX version: DirectX 11

And this is the crash report i get :


Access violation - code c0000005 (first/second chance not available)

20 of these : igd10umd64 + 2539213 bytes
another 10 of these : d3d11 + 525355 bytes

UE4Editor_D3D11RHI!SafeCreateTexture2D() + 24 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\windows\d3d11rhi\private\d3d11texture.cpp:433]

UE4Editor_Core!FRunnableThreadWin::GuardedRun() + 93 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
kernel32 + 88557 bytes
ntdll + 181569 bytes

On the second page of your dxdiag should be a listing of your graphics card information. What information is listed there?

Intel(R) HD Graphics 3000

Dac type: Internal

Memory:1696 MB

Resolution: 1366 x 768 (32 bit) (60Hz)

DirectDraw acceleration : activated

Direct3D acceleration : activated

AGP << : activated

I downloaded namually from intel thelatest updates for my graphic card and now everything is alright. Thank you for your time.

I’ve been experiencing this problem whenever attempting to start Unreal Engine-based games and projects. Whenever the game loads, it suddenly crashes and gives me the “Out of memory trying to allocate a rendering source” message. I’ve seen many threads like this, but none of the answers have worked for me.

I don’t know if it’ll help, but here’s the DxDiag information for my laptop:

System Information

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_ldr.170810-1615)
Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
System Model: HP Pavilion dv6 Notebook PC
BIOS: InsydeH2O Version 03.60.48F.1B
Processor: Intel(R) Core™ i5-2450M CPU @ 2.50GHz (4 CPUs), ~2.5GHz
Memory: 6144MB RAM
Available OS Memory: 6092MB RAM
Page File: 4011MB used, 11241MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

Display Devices

      Card name: Intel(R) HD Graphics Family
   Manufacturer: Intel Corporation
      Chip type: Intel(R) HD Graphics Family
       DAC type: Internal
     Device Key: Enum\PCI\VEN_8086&DEV_0126&SUBSYS_1658103C&REV_09
 Display Memory: 1696 MB

Dedicated Memory: 64 MB
Shared Memory: 1632 MB
Current Mode: 1280 x 768 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: unknown
Monitor Id: AUO22EC
Native Mode: 1366 x 768(p) (60.042Hz)
Output Type: Internal
Driver Name: igdumd64.dll,igd10umd64.dll,igd10umd64.dll,igdumdx32,igd10umd32,igd10umd32
Driver File Version: 8.15.0010.2476 (English)
Driver Version:
DDI Version: 10.1
Driver Model: WDDM 1.1

Sorry for posting it as an answer rather than a comment, but it wasn’t letting me do otherwise.