Download

Error !!!! Help Please

Hi, I followed the instruction video perfectly for downloading the source code from github (with the only difference being I downloaded the lastest version which is 4.0.1, along with the 2 required files zips), so after forking the code with github and cloning it to the desktop, i then proceeded to copy over the required files zips one by one, once complete I then run the GenerateProjects.bat and this is where the error occurs

now because the window goes in a blink of an eye it took a lot of hard work to see what it said,

but when running it just says:

\Microsoft was unexpected at this time

can anybody help or point me in the right direction as to why it will not create the project solution files for visual studio

Thank in advance

Gunner

Can you see if there is any error you could post from the log files?

Well where would the log files be, basically all the engine code is in the git hub repository in MyDocuments/Github/UnrealEngine/[files]

upon trying to run the batch file to create the visual studio .sln [solution] files I just get the above mentioned error

??

what version of Visual Studio do you have installed?

@GunnerJnr,

In Windows, click on Start->cmd.exe . Run this command line (cmd.exe) and drag and drop GenerateProjects.bat and click Enter.This will run that *bat file and should give you a full list of errors, which the *bat file produce.

I have multiple due to being on a Game Programming course, I have VC++ 2008, VS2010, 2012, 2013

As previously mentioned I only get the one error and I have no idea what it means or why ?? That was even following your steps here is a screen shot

Although I have not resolved my issue just yet, I thought I would share this link as it could be a solution for anybody else who has the same error!

http://www.blinnov.com/en/2010/06/04/microsoft-was-unexpected-at-this-time/

Well, it seems that GenerateProjects.bat is not running properly because of your system setup/config. I would recommend you to check the installation guide and double check all Environment Variables. Is your system 64 bit?

Its OKAY, I have managed to solve it now, JUST!!!

Turns out that it was conflicting with Microsoft Direct X SDK 2006, so after successfully uninstalling this version, the batch file has just completed and created the project solution files FINALLY!!!

All I can assume is that after installing the 2006 Direct X SDK (at a later date) after having already installed Direct X SDK 2010, so I guess it must of somehow set that as the default Direct X SDK path, hence why the batch file could not find the path it was looking for, the link I posted in the above post helped a lot.

Hope this post will help any body else who has a similar problem, cheers for your help everyone :slight_smile:

I was having the same issue - dragging the .bat to the cmd window fixed it. It wouldn’t run directly - I have no idea why.

If Gunner reads this: if you make the topic title more descriptive it really helps those of us trying to find fixes. “Error!!!” isn’t very helpful in a search…

This blog (http://www.blinnov.com/en/2010/06/04/microsoft-was-unexpected-at-this-time/) pointed out the underlying issue. There are batch files in Visual Studio’s toolkit that use parentheses to enclose paths. This is ok, unless your path has parentheses in it (most Visual Studio installs are to Program Files (x86) ) and those are enclosed in full quotes (") - then it thinks the close parenthesis at the end of (x86) is the end of statement.

Clean your PATH environment variable of full quotes and all is well. I get the feeling that other things might break, however… I’ll report back if I find anything.