Download

Error Generating Visual Studio Project Files

When I run Generate Visual Studio Project Files, I get the error:
Couldn’t find UnrealBuildTool at ‘D:/UE/Epic Games/UE_5.0EA/Engine/Binaries/DotNET/UnrealBuildTool.exe’

I’ve checked and UnrealBuildTool.exe is located at the specified location.

3 Likes

I have some problem with my project

1 Like

Same here, UE build tool missing. Was so excited to get my project up and running tonight in ue5.
Using visual studio 2019, after generating project files and opening it, the project is empty.

None of the source code in my migrated project can be opened in VS 2019. BUMMER. :thinking:
bummer

Also, When creating new c++ class via the editor, the files are created in the Source folder but they are not added to the Solution file.
I assume this is because of the same failure to find UnrealBuildTool.exe?

I think the bug is UE5 not searching the correct directory for UnrealBuildTool.exe. In UE4, the executable is located at Engine\Binaries\DotNET\, whereas in UE5, it should be Engine\Binaries\DotNET\UnrealBuildTool\. Apparently UE5 is now still looking at the old directory.

HI,

I resolve it like this :
Copy paste the UnrealVersionSelector.exe from the epicLauncher folder to the Binaries folder of the UE5 install then run it to register this UEEngine install
Then i generate the visual project from the tools menu directly in UE5.

But my riderLink breaks beacause it can’t find the UnrealBuildTool.exe -_-. I Wil try to build the UE5 engine this week end and clean all the registery key before that.

Hope it works for you

1 Like

ok
UnrealBuildTool.exe -projectfiles -project=“E:/unrealProjects/Mag/Mag.uproject” -game -rocket -progress

run from cmd work

1 Like

After I run this, it generated/updates the Visual Studio file. But when I open it in VS it is missing the Engine and Programs folders in the Solution Explorer. All I see is my GameName folder (Not inside the Game folder) and a folder named Visualizers. So it seems the game files are not being properly linked with UE5.

I figured it out, to get the Engine files in your solution, you need to add -engine.

UnrealBuildTool.exe -projectfiles -project=“C:\UnrealProjects\ProjectFolder\ProjectName.uproject” -game -Engine -rocket -progress

2 Likes

Is there a way to revert this? As this screwed everything up for me to the point where I can’t open anything anymore.

I got everything working and can see all VS files. It just doesn’t work or want to build with 2017. I need at least 2019 Will try now.

Can confirm this worked for me, running it from within D:\UE5\UnrealEngine\Engine\Binaries\DotNET\AutomationTool in cmd, without any other changes.

As @biubiuty3 mentioned, It seems the conext menu option “Generate Visual Studio Project” is still bounded to the path we used on UE4( Engine\Binaries\DotNET\) instead of the new path on UE5( Engine\Binaries\DotNET\UnrealBuildTool\)
But if you open any project from editor and use the Refresh Visual Studio Project it works without much problem.

I’ll bet that is something related to how windows’ context menu is built.

How did you fix it? @KillerSneak When I rebuilt the files the engine just says the project was made for a different version of the engine and to rebuild it but if I let it try to rebuild it says my project cannot be compiled, anything on this?

First you need: (install)

Summary

https://download.visualstudio.microsoft.com/download/pr/e2c406c9-d40d-442c-b6cd-bc60a84d159f/556f8d45b3f5fa932785e138468a6ee3/dotnet-sdk-3.1.115-win-x64.exe

Changed the UnrealBuildTool.xml
C:\Users\<user name>\AppData\Roaming\Unreal Engine\UnrealBuildTool.xml

mine looks like this:

Summary
<?xml version="1.0" encoding="utf-8" ?>
<Configuration xmlns="https://www.unrealengine.com/BuildConfiguration">
    <WindowsPlatform>
        <Compiler>VisualStudio2019</Compiler>
    </WindowsPlatform>
    <VCProjectFileGenerator>
        <Version>VisualStudio2019</Version>
    </VCProjectFileGenerator>
</Configuration>

Copy paste the UnrealVersionSelector.exe from
(Launcher)
*:\<your install directory>\Epic Games\Launcher\Engine\Binaries\Win64
to
(UE5 install directory)
*:\<your install directory>\Epic Games\UE_5.0EA\Engine\Binaries\Win64
and run the
UnrealVersionSelector.exe

Then I run this from the CMD to build the project files VS files (VS 2019)

Summary

"D:\DNATG\Epic Games\UE_5.0EA\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.exe" -projectfiles -project=“D:\DNATG\UE5\ValleyoftheAncient\ValleyoftheAncient.uproject” -game -Engine -rocket -progress

This is what I noted down at the time of release and it should work (hoping I didn’t forget to note a step)

Hope it helps, if not let me know.

I had the same problem but I copied all the files and folders from the unrealbuildtool folder into the DotNET folder and it worked