Download

Error GenerateProjectFiles.bat llvm.Build.cs Unexpected Characters

I’m getting this error when I call GenerateProjectFiles.bat:

Setting up Unreal Engine 4 project files… While compiling …UnrealEngine\Engine\Intermediate\Build\BuildRules\UE4Rules.dll: …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,1) : error CS1056: Unexpected character ‘¬’ …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,3) : error CS1056: Unexpected character ‘’ …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,12) : error CS1056: Unexpected character ‘¬’ …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,14) : error CS1056: Unexpected character ‘,’ …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,15) : error CS1056: Unexpected character ‘÷’ …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,18) : error CS1056: Unexpected character ‘%’ …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,22) : error CS1056: Unexpected character ‘?’ …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,24) : error CS1056: Unexpected character ‘’ …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,28) : error CS1056: Unexpected character ‘3’ …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,33) : error CS1056: Unexpected character ‘’’ …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,37) : error CS1056: Unexpected character ‘·’ …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,38) : error CS1040: Preprocessor directives must appear as the first non-whitespace character on a line …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,1) : error CS0116: A namespace cannot directly contain members such as fields or methods …UnrealEngine\Engine\Source\ThirdParty\llvm\llvm.Build.cs(1,28) : error CS1001: Identifier expected …UnrealEngine\Engine\Source\ThirdParty\Windows\XInput\XInput.Build.cs(1,6) : error CS1056: Unexpected character ‘’ …UnrealEngine\Engine\Source\ThirdParty\Windows\XInput\XInput.Build.cs(1,1) : error CS0116: A namespace cannot directly contain members such as fields or methods ERROR: UnrealBuildTool Exception: Unable to compile source files.

GenerateProjectFiles ERROR: UnrealBuildTool was unable to generate project files.

I’ve tried ensuring every visual studio component I’ve seen in any tutorial I could find is installed and didn’t run into any issues forking and cloning from github and running setup.bat. Any ideas what I could be doing wrong? I’ve been banging my head here for a few hours. Thanks in advance.

So I ended up deleting my original clone of the release branch and re-cloned the branch from the GIT repository. Then I ran setup.bat as an administrator and once that was finished ran GenerateProjectFiles.bat again as an administrator. This time it generate the solution file!