"Error Deployment failed! Failed to sign executable. Make sure your developer certificates have been installed in the System Keychain on the remote Mac."

When attempting to launch to my iPhone via remote build, I get this error.

I followed the instructions in the iOS Quick Start Guide to set up my certificate and provisioning profile. However, while I have the certificate listed in the System section of Keychain on my Mac, there’s no option to expand it to see the Signing ID.

When doing a remote build, do the certificate and provisioning profile have to be generated from Xcode on the Mac? I created them from the Apple developer website and then download them to both my Mac and PC

Hi drummerof13,

  • Make sure you are on the latest version of UE4.13 (ie. UE4.13.2)
  • Which Keychain is your certificate in on the mac? If it is in the login keychain, it might need to be in the system keychain (and vice versa).

If the above doesn’t help, please check these similar AnswerHub Posts for a possible solution:

If none of the above help, let me know and we will continue to investigate. Please also include a copy of the entire output log as an attached text file; do not send screenshots.




Thanks for the suggestions!

  • I am on 4.13.2.
  • I tried the certificate in both the System keychain and the Login keychain.
  • Both my Mobile Provision and Certificate listed in Project Settings say “Valid”.

For the other AnswerHub posts:

  • RSync: the resolution was to put the certificate in the System keychain, which I have done. It also mentions exporting a certificate from XCode, which I can’t seem to manage. I just downloaded the certificate/provisioning profile from the Apple Developer website and imported it both into UE4 on my PC and XCode.
  • iOS Remote Build Tool: this one mentions fixing the issue by associating a private key with the certificate in the system keychain. I’ve searched, but I can’t figure out how to add a private key to that certificate. I’ve tried revoking my certificate, making a new one, downloading it, and opening it, but there is still no private key.
  • Remote Connection: In the bug report, it says “Make sure bundle ID matches signing ID”, but I’m not sure where to find the exact name of the signing ID. It appears that I can do so from Xcode, but I don’t have a project in Xcode. There is a workaround on this post, but it uses C++, and my project is Blueprints-only.

One thing that might be key here is the log says "No “iOS Development” signing certificate matching team ID “***” with a private key was found. The team ID listed is out of date. I’m not sure where this team ID is pulling from because everywhere I can see (Project Settings and .plist files) it shows the correct team ID. Also, as I mentioned above, there is no private key listed under the certificate in Keychain.

One more thing: in the iPhonePackager, the checkbox next to “Import a mobile provision” is yellow, while the one next to “Import a certificate” is green.

Attached is my log file. Thank you so much for your help!

It looks like from your logs that your certificates are set up properly for your PC but not your Mac. When you downloaded the certificates, did you install them on your Mac through the Editor>Project Settings>? If so, you may want to try the following:

Open XCode: Preferences: Accounts:

If you have not done so already, add your Apple ID and manage your certificates and provisions through this account.

If this does not resolve the issue, please post of screen shot of your Project settings… They should appear like this, do not check boxes by certs & provisions, let UE4 choose automatically

Thanks again for your help, . UE4 isn’t set up on my Mac (not the same version as my PC, anyway).

I already have my certificate and provision added in XCode > Preferences > Accounts. Although name just says “drummerof13” instead of the long phrase I would expect.

Here are my settings from my PC installation of 4.13.2. It appears that I’m missing something from the provisions:

If you have room, please add the same edition of UE4 on your Mac and see if this makes a difference. Your provisions look fine in the image above. If this doesn’t work, it will be after the Thanksgiving Holiday before I can another look at this.

I got it!!! My problem was that I generated the certificate from the Apple Developer website instead of XCode. Even though I had imported the certificate into XCode, something about it wasn’t correct because it didn’t have an associated Private Key.

So I went into XCode > Preferences > select developer profile > View Details and clicked Reset next to my Developer Certificate (if I hadn’t previously imported it into XCode, it would have let me click Create instead of Reset). I was then able to right-click the certificate and export it. I brought the new certificate into Keychain and saw that it had a Private Key under it. I moved it to the System keychain.

After that, I copied the certificate to my PC and imported it using the IPhonePackager. After that it still failed to launch on my iPhone, but turning of Wi-Fi fixed it, and now it’s working!!!

Thank you for posting your resolution. I’m sure this will help a lot of users who find themselves in a similar situation.