ERROR - Crash on Play

[2016.06.09-19.25.27:024][637]LogPlayLevel: PlayLevel: No blueprints needed recompiling
[2016.06.09-19.25.27:025][637]PIE: New page: PIE session: MainLevel (Jun 9, 2016, 10:25:27 AM)
[2016.06.09-19.25.27:026][637]LogPlayLevel: Creating play world package: /Game/_CyberShot/UEDPIE_0_MainLevel
[2016.06.09-19.25.27:102][637]LogPlayLevel: PIE: StaticDuplicateObject took: (0.076015s)
[2016.06.09-19.25.27:105][637]LogAIModule: Creating AISystem for world MainLevel
[2016.06.09-19.25.27:106][637]LogPlayLevel: PIE: World Init took: (0.003403s)
[2016.06.09-19.25.27:107][637]LogPlayLevel: PIE: Created PIE world by copying editor world from /Game/_CyberShot/MainLevel.MainLevel to /Game/_CyberShot/UEDPIE_0_MainLevel.MainLevel (0.081237s)
[2016.06.09-19.25.27:107][637]LogActorComponent: UnregisterComponent: (/Engine/Transient.CharMoveComp) Not registered. Aborting.
[2016.06.09-19.25.27:151][637]LogInit: XAudio2 using ‘Speakers (Realtek High Definition Audio)’ : 2 channels at 48 kHz using 32 bits per sample (channel mask 0x3)
[2016.06.09-19.25.27:169][637]LogInit: FAudioDevice initialized.
[2016.06.09-19.25.27:241][637]LogWorld: Game class is ‘GM_1_BP_C’
[2016.06.09-19.25.27:283][637]LogWorld: Bringing World /Game/_CyberShot/UEDPIE_0_MainLevel.MainLevel up for play (max tick rate 60) at 2016.06.09-15.25.27
[2016.06.09-19.25.27:285][637]LogWorld: Bringing up level for play took: 0.041372
[2016.06.09-19.25.27:331][637]LogContentBrowser: Native class hierarchy updated for ‘MovieSceneCapture’ in 0.0040 seconds. Added 9 classes and 0 folders.
[2016.06.09-19.44.48:989][637]LogOutputDevice:Warning:

Script Stack:
HUD003_C.ExecuteUbergraph_HUD003

[2016.06.09-19.44.49:078][637]LogWindows:Error: Windows GetLastError: The operation completed successfully. (0)

Hey JayGhoul,

  • Which PIE mode are you using? Selected Viewport, New Editor Window, or Mobile Preview?

  • Have you built all before trying to Play In Editor?

  • Have you run Build> Map Check?

  • In the following error above this is the last message before the editor aborts PIE:

    LogActorComponent: UnregisterComponent: (/Engine/Transient.CharMoveComp) Not registered. Aborting

-Which appears to be a problem with the Character Movement Component..

Please review the information on the link above and let me know if this does not help you resolve your issue.

Thanks,

Steve H.

  1. I am using Selected Viewport.
  2. Yes, I have built all before trying to play in Editor.
  3. Yes, I have run Build → Map Check.
  4. I am very aware of that being the error message and there has yet to be anything to fix it. Before anyone asks, No I have not edited the (Engine/Transient.CharMoveComp) in any way shape or form I have just created blueprints and C++ classes that are children to the Character Class. And yes, I know how Character Movement Component works and I know that it isnt a problem with anything I am doing but the engine is messing up. This is the same problem that was occurring before the most recent update (I think 4.11.2) and now it is just crashing instead of not loading the player like it used to. This is related to the earlier problem that people posted with the same error who also received remotely no help from UE4 staff.

I have had this problem for countless days now and was looking for help on Twitter, other posts, and other websites even and still no help. I have done everything in my power to fix it and there is no way (To my knowledge) that this isn’t an engine bug problem. (Just my personal thoughts)

Still a probelm in 4.12.2 please fix this fast D:

  1. Does the Crash Reporter alert appear when the editor Crashes?
  2. If so, have you hit Submit on the Crash Reporter alert?
  3. If so, please post the Machine ID from the Crash Reporter alert window so I can locate your crash and compare it with our crash reporter data. (If you do not want to post that publicly, you can send it to me in a private message on our Forum Page.)
  4. If this is the same problem that was occurring in UE4.11.2, please point to an AnswerHub or Forum post where this was reported.

Hey JayGhoul,

Since we have not heard back from you in a few days, we are marking this resolved for tracking purposes. However, if you feel this is related to a previous issue in UE4.11.2, please either point to the AnswerHub or Forum post where this specific issue was reported or supply steps for us to reproduce the issue in-house.

Thanks,

Steve H.