Error C4430: missing type specifier - int assumed

I have been getting the following error upon compiling for some time and haven’t yet found a solution. If anybody could offer some help I would greatly appreicate it.
C:\Program Files\Epic Games\UE_4.25\Engine\Source\Runtime\Engine\Classes\Components/PrimitiveComponent.h(2386): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
I don’t recall modifying this file in any way either.

1 Like

Hello Harrison,
Have you solved your problem? I keep getting the same error in SceneComponent.h today

Usually the cause of this error is incorrect formating in your code. It may be missing bracket or semicolon, anything that would lead to header included next to your code to fail to parse first term, the type of variable\function.

As for searching the root cause - check the last files you modified or attempt to search which file is included right before the one the compiler shown in error message(may be not so trivial task).

That error is typically because you missed a header, have a look at which classes you added and check that you have their header included in the .cpp or .h


#include "Components/SceneComponent.h"