Download

error C2065: 'bAttributeLessDraw': undeclared identifier:build failed with 4.11.0 release source

I download latest release source zip(UE4.11) from github, then I run setup.bat, then I run GenerateProjectFiles.bat. then I build with VS2015(DebugGame Editor, win64), but can’t compile successfully, therer are two error :

I am getting this exact error, it seems someone has pushed the latest build with some errors. Just comment or remove the code bellow and save that document and should work fine.

OpenGLCommands.cpp


	
//  @Todo Workaround for radr://15076670 "Incorrect gl_VertexID in GLSL for glDrawElementsInstanced without vertex streams on Nvidia”
#if PLATFORM_MAC
	if(bAttributeLessDraw)
	{
		glDisableVertexAttribArray(0);
		ContextState.VertexAttrs[0].bEnabled = false;
		ContextState.VertexStreams[0].VertexBuffer = nullptr;
	}
#endif


Exactly! thx so mush for help!

I resolve it otherwise by re-saving the OpenGLCommands.cpp from UT8 w/o BOM to UTF8 w/ BOM.

Since I am compiling against PC platform, there is no sense that deleting a code snippet wrapped by PLATFORM_MAC would work.

This png explains in details.

给力给力!多谢帮助!

我昨天下4.11遇到了这个问题,先搜到了你的问题和这个帖子,觉得解决方案不怎么make sense所以就研究了一下,刚好6年前在2k china做过borderlands的日文本地化,对编码有点了解。
不谢,论坛就是互相帮助的。

Translation for others(Since this is a English forum):
I met this problem yesterday after downloading 4.11, I got your answer hub thread and this forum thread by searching, but I didn’t think the solution make sense, so I dug a little further. I just happen to have some knowledge in file encoding due to my 6 years ago working experience in 2k china for borderlands’ Japanese localization.
You’re welcome, the forum exists for us helping each other.

Just simply change line 2793, replace \u201D with "(use regex), and save.

You might need to switch to UTF8 BOM and save in order to find this Unicode Character.

This is because \u201D is a RIGHT DOUBLE QUOTATION MARK, which is widely used in Asia countries. it’s a common typo bug.