Error C1083: dirent.h: No such file or directory (Can't include)

The library file is not included. Error C1083: dirent.h: No such file or directory. When packaging the plugin on UE4. At the same time, everything is successfully packaged on UE5.
I tried both “” quotes and <>. I transferred the file itself inside the plugin. It didn’t help

I cut out the contents of the include file by inserting it into the beginning of the code - everything worked. For some reason, UE4 does not see the path to the file. Although it finds it perfectly on UE5. The development environment is the same VS

1 Like

Hey @AndroWin!

It’s a little hard to tell since there it is only a part of a line instead of the whole error log, however it looks like there are some non-ANSI letters (unrecognised non plain letter english letters) which the system is having trouble with. Adjusting those characters may solve your problem.

If it does not, please upload your full error log.

I hope the above solution works for you!

1 Like