Download

Error Blueprint Runtime Error: Accessed None trying to read property AnimInstance from function

I am using a second animation bluebrint
on an existing character bp with Retargeting feature.
There are no compile errors in the editor,
Only errors pop out after playing.
Im trying to use the IK feature here, the IK worked fine with the original Animation BP, but after retargeting it goes haywire.
I tried to use “is valid” the error goes away, but still the IK doesnt work

You are casting to Character instead of RavanaCharacter. Also don’t chain casts.

so I only need to cast to ravanacharacter?

I got rid of cast to character, but still the problem persists

Is the character BP set up to use the right animation BP?

yeah, the skeletal mesh and the animation BP are correctly set.

all the other settings work fine, like attacking, movement and jumping notifies, except this

How are you setting the anim instance in the character BP?

Heres some pic from the ikupdate function

heres the anim bp added to the character bp

Okay, never seen that way of setting it, a possibly better way is to get the skeletal mesh component (drag it into the BP), get the anim instance, cast it to your anim bp (right clicking to make it a true cast) then saving the result as a variable. Then you shouldn’t get any errors.

OMG!!! that works, thanks alot, was banging my head against the wall the whole day.

You need to actually attach the execution wire for the variable. I thought this was obvious…
Also did you really need to bump this thread? You could have just posted this in your PM to me.