Error "armv7\gradle\rungradle.bat :app:assembleDebug" when pakcaging for android

I keep getting this error when packaging for android and I have tried everything I can find online
(Android Studio 3.5.3, 4.0, 4.2.2 (documentation says I need 4.0 and 3.5.3 on the same page btw), run the Android Setup (where I dont get a prompt to accept the license), sdk reinstallation, custom windows environment values)

Does someone know how I can fix it? I’m building for the quest 2 with unreal 4.26

ERROR: cmd.exe failed with args /c "D:\Game Dev\Unreal Projects\[project]\Intermediate\Android\armv7\gradle\rungradle.bat" :app:assembleDebug

If you need more info let me know.

1 Like

Any luck fixing the issue?
I have the same problem

1 Like

In android studio I uninstalled the all NDKs and installed v29 and it worked!
Will post a video on it on my channel Dev Dunk this week :stuck_out_tongue:


Delete the intermediate folder of your project and open it again, then try to package <3


i deleted it but still no luck same error

How?? There is no version called v29 for Unreal engine 4.27. And I can’t find your video on your channel…

If people are still struggling, for me I had to try some different SDK/NDK versions. Check the docs and try the appropriate versions instead of the ones Android Studio recommend