Error 1720, installing Epic Games Launcher

While installing the Epic Games Launcher using the command (msiexec /i “C:\EpicGamesLauncherInstaller-2.0.1-2467307.msi” SKIP_DIRECTX=“1” /L*V “C:\EpicGamesInstallerLog.txt”) I get the error message:

“There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor.”

Here’s the install log

Action “StripInstallDirSlash” seems to be causing error 1720.

System specs:
Windows 7 Home Premium 64bit,
i7 quad core,
6gb RAM,
NVIDIA GeForce GT 330M

Any help will be greatly appreciated, thanks! :slight_smile:

Hi A Rabbit,

Try the excepted solution in this post. If it doesn’t work for you, please let us know and post a copy of your entire dxdiag (system specs).

Hi TJ Ballard,

Thanks for the reply, I think you forgot to add a link to the excepted solution of the post you mentioned, here’s my dxdiag.

Sorry about that, it’s been added.

np :slight_smile:
I’ve reinstalled direct x as mentioned in the post you linked to, and I already use the SKIP_DIRECTX=“1” argument when running the msi through the cmd, however I still get the 1720 error during the “StripInstallDirSlash” action, thanks for the suggestion.

I believe the issue could be with your Graphics card. It only supports up to DirectX 10 and a DX11 compatible card is recommended. We have had users install the Launcher and Editor with a DX10 card but rendering will be limited.

Make sure that your graphics card drivers are up to date and that you don’t have the beta driver. They can sometimes be unstable.

Thanks TJ Ballard, I’ve updated my graphic card drivers but still no luck. I’ll probably have to get a new laptop ^^

Hi A.Rabbit,

It sounds like you might not be running the latest windows installer. Can you open the command prompt and input “msiexec ?” (without the quotations). A new window should pop up and at the top it should show a version number. What version are you on?

-Max B.

Hi Maximusdb3,

My current version of msi is: 5.0.7601.17514

Hi A.Rabbit,

I’m sorry we have not been able to help you with this issue. Thank you for providing your installer log file. I have been investigating it for some time now but I’m still unable to pinpoint the reason you are seeing this. In short, the error you are seeing is encountered when we try to run one of our VBScript Windows Installer custom actions. As far as I’m aware, we have not seen this custom action fail in any other cases so I’m not sure why you would be seeing this problem. In the future my plan is to move away from using VBScript in our custom actions but I realize that this does not immediately help you. I will open a ticket to investigate further.

Here is a workaround that should get you past the issue. This is a very specific workaround for issues where the installer log shows that the StripInstallDirSlash custom action is failing with error code 1720. This will not work for other 1720 error code issues.

Workaround

  1. Download the latest Epic Games Installer
  2. Run the installer using the following commandline(replace C:\EpicGamesLauncherInstaller.msi with the path/name of the installer you downloaded): msiexec /i “C:\EpicGamesLauncherInstaller.msi” SKIP_PERMISSIONS_INSTALLFOLDER=“1” SKIP_PERMISSIONS_APPDATA=“1” SKIP_AUTOLAUNCH="1"
  3. Set user permissions on the install folder. This can be done a number of ways but the simplest may be to run this commandline(replace C:\Program Files\Epic Games with your selected install location): icacls.exe “C:\Program Files\Epic Games” /grant “BUILTIN\Users”:(OI)(CI)F
  4. Set user permissions on the ProgramData folder. This can be done a number of ways but the simplest may be to run this commandline(replace C:\ProgramData\Epic with the location of your Epic AppData folder): icacls.exe “C:\ProgramData\Epic” /grant “BUILTIN\Users”:(OI)(CI)F
  5. If steps 3 and 4 completed successfully, try launching using the Epic Games shortcut on your desktop or in your start menu

You.
Are.
My [REDACTED] redentor!!!
Thanks!!!

Thank you. Only took 5 hours to find your post. Had to help a friend for the Fortnight install so it took longer to get here. Thank you again for time and awesome help (: