ER:cmd.exe failed with args /c"..Intermediate\Android\armv7\gradle\rungradle.bat":app:assembleDebug


I am really stuck here… tried to go through most of the online support available, but there is no end to this agony…the frogs curd(pun intended) is never forming…help.

Error log while creating an multi android package for 4.25.3 unreal version.:
followed this video guide to the end or probably there was a mistake done by me. but I have tried it multiple times ,unable to focus on the core issue.

UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): * What went wrong:
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): A problem occurred configuring root project ‘app’.
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): > Could not resolve all dependencies for configuration ‘:classpath’.
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): > C:\Users\siddharth.gradle\caches\modules-2\modules-2.lock (Access is denied)
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): * Try:
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): * Get more help at
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): BUILD FAILED in 4s
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): ERROR: cmd.exe failed with args /c “F:\unreal1 est1\Intermediate\Android\armv7\gradle\rungradle.bat” :app:assembleDebug
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): (see C:\Users\siddharth\AppData\Roaming\Unreal Engine\AutomationTool\Logs\G+Program+Files+Epic+Games+UE_4.25\Log.txt for full exception trace)
PackagingResults: Error: cmd.exe failed with args /c “F:\unreal1 est1\Intermediate\Android\armv7\gradle\rungradle.bat” :app:assembleDebug
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): AutomationTool exiting with ExitCode=1 (Error_Unknown)
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): BUILD FAILED
PackagingResults: Error: Unknown Error
LogSlate: Took 0.000130 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Slate/Fonts/DroidSansMono.ttf’ (77K)

1 Like

Did you solve the problem ?

1 Like

Did you?

If somebody stumbles upon this error, this is what helped me on 27AUG2021 (adding timestamp, it might become obsolete in future):

YT/watch?v=cLveaVXOKKc * hopefully the YT link above works

1 Like

I have the same problem today.
I try to redownload gradle. doesn’t work.
Finally , In SDK manager with Android Studio, I removed the lasted Build tool, It works well.
My UE4 reversion is 4.26.2 ,Android sdk is 5.x- 11.x,NDK21, jdk18, build tool all r31-r33).