Download

Equip Weapon

Hi, I’m trying to equip the weapon to the player’s hand when interacted with, but for some reason it’s staying on the ground, even though everything is being called and executing as it should, and it says I have the correct weapon equipped in debugging, I’m not sure where I’m going wrong

Since the weapon reference part is working fine, have you tried setting the Location Rule to “Snap to Target” when calling the AttachActorToComponent node?

Yeah I tried that, it was all working until I changed the collision settings, enabled physics, and added the ‘Set Collision and Physics’ function, but they shouldn’t have affected it teleporting to the hand, and I’ve even tried reverting them back nothing seems to fix it.

As far as I can tell, the blueprint logic is fine. Something else causes the issue.

Okay, I’m at a complete and utter loss, I’ve tried everything I can think of, breakpoints are pausing it at the correct times, all values are reading correct, I even created a separate blueprint actor to test with, using just a cube mesh and the interact function in the interface, attaching the actor to the component, and that works perfectly, attaching to the correct socket and moving with it, even though all the physics and collision settings are exactly the same as the weapon blueprint, so I have absolutely no idea what’s causing the issue